Scrolling in FF 4 beta 5 is worse than FF 3.6.9

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: r_rom, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b5) Gecko/20100101 Firefox/4.0b5
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

Very noticeable! One of pages on which I've noticed this is http://www.mozilla.com/en-US/firefox/4.0b5/releasenotes/. With fresh profile.

Reproducible: Always
(Reporter)

Updated

8 years ago
Summary: Scrolling in FF 4 beta 5 is worse than FF 3.6.8 → Scrolling in FF 4 beta 5 is worse than FF 3.6.9
Is your Issue reproduceable Extension-less in Safe-Mode and/or using a new Profile?
https://support.mozilla.com/en-US/kb/Safe+Mode
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile

Does disabling Hardware Acceleration under Options/Advanced/General help?
If yes, please provide the Graphics Info from about:support (on the Bottom).
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
Yes, a new profile. Disabling Hardware Acceleration does NOT help.

The difference isn't as big as it's in demos of IE 9 when compared to other browsers but is noticeable. Here's another page on which I perceive it: http://doophp.com/forum/viewforum.php?f=7.

Here's the Graphics Info:

Adapter Description NVIDIA GeForce Go 6150
Vendor ID 10de
Device ID 0244
Adapter RAM 64
Adapter Drivers nvd3dum nvwgf2um
Driver Version 7.15.11.7967
Driver Date 3-6-2009
Direct2D Enabled false
DirectWrite Enabled false

Comment 3

8 years ago
Disabling HW acceleration is taken into account only after a FF restart.
So, do you still have the problem without HW acceleration ?
If HW acceleration is the cause, could you update your graphic driver to the latest one (issue date : 2010.07.19). Go to your laptop support site or nvidia support site ("windows 7 update" service is in late for graphic driver update) :
http://www.nvidia.com/object/win7-winvista-32bit-258.96-whql-driver.html
(Reporter)

Comment 4

8 years ago
I've tried disabling HW acceleration but hadn't noticed an affect.

It's not always easy to detect the difference between how FF 4 b5 does scrolling and how FF 3.6.9 does it. Scrolling in 3.6.9 seems smoother, but I wouldn't bet my life on it.

The new driver couldn't be installed on my laptop because the installation program didn't find drivers compatible with my hardware.

Comment 5

8 years ago
Are you sure the scrolling behavior is identical in FF 3.6.9 and FF 4.0b5 :
Go to Options > Advanced, and check if the 2 following options are ticked the same way :
+ Use auto scrolling
+ Use smooth scrolling

For graphic driver update, you can do it manually :
http://www.addictivetips.com/windows-tips/how-to-install-hardware-or-device-drivers-manually-in-windows-vista/

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.