Closed Bug 594294 Opened 9 years ago Closed 9 years ago

popup blocker icon in status bar needs new home in primary UI

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 588317
Tracking Status
blocking2.0 --- -

People

(Reporter: dietrich, Unassigned)

References

Details

currently we show an icon on the right end of the status bar when firefox blocks a popup for you. now that the status bar is going away, we need to find a new home for it, or make a decision about whether it's necessary.
OS: Linux → All
Hardware: x86 → All
once the status bar is removed, search mxr for this bug's number to see the places that need re-enabling and updating.

cc'ing UX folks so that this gets on the radar.

requesting blocking because once the statusbar is gone, and user chooses "don't show message", there's no way for the user to know that Firefox blocked a popup.

and maybe there doesn't need to be.

but getting this rolling to confirm one way or the other.
blocking2.0: --- → ?
the long term plan is bug 588317, in the meantime we can just rely on the current notification bar to provide users with access to pop-ups.
Sounds like comment 2 asserts blocking- on this bug.
blocking2.0: ? → -
Or just turn it into a customizable widget and throw it in the customize dialog.
Blocks: 604419
I would assert that this is still necessary. I don't like the big gold bar at the top of the screen to show up every time a popup gets blocked. However, I like the functionality to show the popup that was blocked if I clicked on the old icon on the status bar. Maybe something can show up at the end of the address bar or there can be a balloon notification like the new remember password UI?
Blocks: 610349
Duping to bug 588317 since we want to move both the popup blocker bar and icon to a location bar lucky charm.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 588317
You need to log in before you can comment on or make changes to this bug.