Crashing in layout when loading my.netscape.com page

RESOLVED WORKSFORME

Status

()

Core
Layout
P1
critical
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: kinmoz, Assigned: buster)

Tracking

({crash, regression, top100})

Trunk
x86
Windows NT
crash, regression, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Using the Win32 2000110616 Netscape 6 opt build (based on the 
Netscape_20000922_BRANCH), I crash when going to my.netscape.com.

Because it's an opt build, I'm not able to get a real meaningful stack trace, 
but it does show that it's crashing somewhere in layout:

GKHTML! 60217975()
GKHTML! 60217034()
GKHTML! 60216df7()
GKHTML! 60216129()
GKHTML! 6021e09a()
GKHTML! 6021de52()
GKHTML! 60217b1f()
GKHTML! 60217034()
GKHTML! 60216df7()
GKHTML! 60216129()
GKHTML! 6020b84a()
GKHTML! 601f4afe()
GKHTML! 602ae158()
GKHTML! 602add51()
GKHTML! 602a85fa()
GKHTML! 602a85fa()
GKHTML! 602ca168()
GKHTML! 602ca193()
GKHTML! 602a85fa()
GKHTML! 602c9b79()
GKHTML! 6020b84a()
GKHTML! 602c8ba5()
GKHTML! 6020ed76()
GKHTML! 60207411()
GKHTML! 60207279()
XPCOM! 60cce166()


I tried to reproduce the problem in my Netscape_20000922_BRANCH debug build from 
this morning, but I don't crash, instead, I see a ton of warnings spewed out 
into the console. I'll be attatching the console output shortly.
(Reporter)

Comment 1

18 years ago
Created attachment 18911 [details]
Warnings printed in console.
(Reporter)

Comment 2

18 years ago
Created attachment 18912 [details]
My.netscape.com page that crashes or spews warnings.
(Reporter)

Comment 3

18 years ago
Adding regression keyword, since I don't think this was happening last week.
Keywords: regression
(Assignee)

Comment 4

18 years ago
making very high priority
Severity: normal → critical
Status: NEW → ASSIGNED
Keywords: crash, top100
Priority: P3 → P1
(Assignee)

Comment 5

18 years ago
On today's trunk build, I get no errors from layout with the attached test case
on WinNT.

Kin, can you verify that this is no longer a problem?
(Reporter)

Comment 6

18 years ago
I'm able to load the test case and my my.netscape.com page without layout errors
with my debug Win32 trunk build from this morning. We still need make sure the
opt builds don't crash.
(Assignee)

Comment 7

17 years ago
tried both debug and opt builds on the attached test case, and several
variations of my.netscape.com live pages vended from the server.  no crashes on
WinNT.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.