Console clickable items pick up events that they shouldn't

VERIFIED FIXED

Status

()

Firefox
Developer Tools
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Kevin Dangoor, Assigned: msucan)

Tracking

({polish})

unspecified
polish
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [Web-Console-Testday])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

7 years ago
If you right-click or click and drag (to select) in the console and you happen to mousedown on a clickable item (such as objects or network traffic), the panel pops up even though it wasn't desired.
(Assignee)

Comment 1

7 years ago
Created attachment 474016 [details] [diff] [review]
proposed fix and test code

This is the proposed fix and test code.

Please note that this patch fixes the following issues:

- the network/property panels should not open when the user middle/right-clicks the output.
- the panels should not open when the user performs a selection gesture in the output.
- the panels should not open multiple times for the same output.

Any feedback is welcome!
Attachment #474016 - Flags: feedback?(rcampbell)
(Assignee)

Updated

7 years ago
Status: NEW → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [patchclean:0910]
Comment on attachment 474016 [details] [diff] [review]
proposed fix and test code

you're adding the close button to this? That seems extraneous to the purpose of this bug. Might want to at least add it to your list of "features".

I'm not sure this is required given that the titlebars have close buttons on them now.

The rest looks decent.
Attachment #474016 - Flags: feedback?(rcampbell) → feedback+
(Assignee)

Comment 3

7 years ago
(In reply to comment #2)
> Comment on attachment 474016 [details] [diff] [review]
> proposed fix and test code
> 
> you're adding the close button to this? That seems extraneous to the purpose of
> this bug. Might want to at least add it to your list of "features".
> 
> I'm not sure this is required given that the titlebars have close buttons on
> them now.
> 
> The rest looks decent.

I am not adding the close button. That was and is there, as intended by Julian.

What I am adding is a class name to the close button such that I can easily find the close button element from other code (the test).

Thanks for your feedback+!
(Assignee)

Comment 4

7 years ago
Comment on attachment 474016 [details] [diff] [review]
proposed fix and test code

Asking for review from Shawn. This is UI polish for the WebConsole.
Attachment #474016 - Flags: review?(sdwilsh)
Comment on attachment 474016 [details] [diff] [review]
proposed fix and test code

Please use the public domain license block for the test per http://www.mozilla.org/MPL/license-policy.html

r=sdwilsh
Attachment #474016 - Flags: review?(sdwilsh) → review+
(Assignee)

Comment 6

7 years ago
(In reply to comment #5)
> Comment on attachment 474016 [details] [diff] [review]
> proposed fix and test code
> 
> Please use the public domain license block for the test per
> http://www.mozilla.org/MPL/license-policy.html
> 
> r=sdwilsh

I would prefer to keep code I contribute in any of the allowed code contribution licenses by Mozilla (MPL or GPL), except PD. I agree with PD for all but the smallest testcases.

Thank you for understanding, and for the review!
(Assignee)

Comment 7

7 years ago
Comment on attachment 474016 [details] [diff] [review]
proposed fix and test code

Asking for approval2.0+ to fix an obvious issue in the Web Console UI. Currently users can click output items multiple times and they get duplicated panels, they can also right-click the output to open panels, or middle click. This patch fixes the usabilities issues associated to clickable output items. Thanks!
Attachment #474016 - Flags: approval2.0?
(In reply to comment #6)
> I would prefer to keep code I contribute in any of the allowed code
> contribution licenses by Mozilla (MPL or GPL), except PD. I agree with PD for
> all but the smallest testcases.
Then you need to actually use the boilerplate (http://www.mozilla.org/MPL/boilerplate-1.1/mpl-tri-license-c) and follow it's formatting instead of copying some test that isn't formatted correctly.
(Assignee)

Comment 9

7 years ago
Created attachment 475038 [details] [diff] [review]
rebased patch

Thanks Shawn! I have rebased the patch because it bitrotted, and now I also changed its license to PD.

Forward-porting the approval2.0? flag. This patch does UI polish for the Web Console, and we'd like it checked-in. Thanks!
Attachment #474016 - Attachment is obsolete: true
Attachment #475038 - Flags: approval2.0?
Attachment #474016 - Flags: approval2.0?
(Assignee)

Updated

7 years ago
Whiteboard: [patchclean:0910] → [patchclean:0914]
this is an annoying bug. Requesting blocking final or approval.
blocking2.0: --- → ?
Duplicate of this bug: 600055
Keywords: polish
this includes fixes for usability from bug 600055 which was marked blocking final.
(Reporter)

Updated

7 years ago
Blocks: 594225
No longer blocks: 593957

Updated

7 years ago
Duplicate of this bug: 603089
UI popping open unexpectedly. Blocking+.
blocking2.0: ? → final+
(Assignee)

Comment 15

7 years ago
Created attachment 482339 [details] [diff] [review]
rebased patch

Rebased patch. Only made test changes.
Attachment #475038 - Attachment is obsolete: true
Attachment #475038 - Flags: approval2.0?
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
Whiteboard: [patchclean:0914] → [patchclean:1011]

Comment 16

7 years ago
http://hg.mozilla.org/mozilla-central/rev/bdbece127d76
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [patchclean:1011]

Updated

7 years ago
Duplicate of this bug: 604618

Updated

7 years ago
Status: RESOLVED → VERIFIED
Whiteboard: [Web-Console-Testday]
You need to log in before you can comment on or make changes to this bug.