disabled number box styling is broken

RESOLVED FIXED in mozilla2.0b7

Status

()

Toolkit
Themes
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Gavin, Assigned: mstange)

Tracking

Trunk
mozilla2.0b7
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

The text isn't greyed out, and the cursor is wrong too.

<textbox type="number" disabled="true" value="20"/>
Created attachment 473149 [details] [diff] [review]
patch?

This seems to fix it, but I don't really know if there's a better way to do this, or whether this is complete given the other styling in that file.
Attachment #473149 - Flags: feedback?(enndeakin)

Comment 2

7 years ago
Why does this only affect Mac?
Is this a regression?
(Assignee)

Comment 4

7 years ago
I think you just need to remove the color and cursor properties from the .numberbox-input-box rule in numberbox.css. The correct color is already set on the textbox and just needs to be inherited down properly. For the non-disabled case, cursor:text is set by forms.css on the html:input and doesn't need to be set on the .numberbox-input-box.
Comment on attachment 473149 [details] [diff] [review]
patch?

I have no idea if this ever worked, or why it only affects Mac. Sounds like Markus' suggestion is better, though.
Attachment #473149 - Flags: feedback?(enndeakin)
(Assignee)

Comment 6

7 years ago
Created attachment 475554 [details] [diff] [review]
v1

Can you test this on Linux?
Assignee: nobody → mstange
Attachment #473149 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #475554 - Flags: review?(dao)
Works for me on Linux - cursor is "text" when enabled, normal when disabled.

Updated

7 years ago
Attachment #475554 - Flags: review?(dao) → review+
(Assignee)

Updated

7 years ago
Attachment #475554 - Flags: approval2.0?
Attachment #475554 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 8

7 years ago
http://hg.mozilla.org/mozilla-central/rev/8130457aed61
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8

Updated

7 years ago
Target Milestone: mozilla2.0b8 → mozilla2.0b7
You need to log in before you can comment on or make changes to this bug.