Generate unique id for a push in schedulerdb/statusdb

RESOLVED DUPLICATE of bug 570814

Status

Release Engineering
General
P3
normal
RESOLVED DUPLICATE of bug 570814
7 years ago
4 years ago

People

(Reporter: anamarias, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Generate unique identifiers every time a push starts. This way all build requests (builds, unittests and talos) will have the same id. The tests will inherit this id from the build triggering them.

All build will have the same unique id for all platforms.

The id should be unique across masters.

Right now there is no way to tell if the tests generated by a nightly build run belongs to an actual build started around the same time or to a nightly build. For example this build run http://cruncher.build.mozilla.org/buildapi/reports/revision/mozilla-central/4b879b793eb6 contains extra build requests from a nightly build, and displays 271 buildrequests instead of ~167.

Problems:
* forced builds wont get the unique ID right now
* rebuilds --> same id
(Reporter)

Updated

7 years ago
See Also: → bug 567049
(Reporter)

Updated

7 years ago
Blocks: 559880
(Reporter)

Updated

7 years ago
Blocks: 559885
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 570814
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.