"Next Steps" and other links missing from right-hand column of Drumbeat project page

RESOLVED WONTFIX

Status

Websites Graveyard
www.drumbeat.org
RESOLVED WONTFIX
8 years ago
4 years ago

People

(Reporter: B. Kip, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8
Build Identifier: 

This is affecting all the pages on my project, however, when checking other random projects on the site some have links in the right hand column and some don't.  Generally, if a site simply hasn't entered any links, the title 'Links' still appears in the lower part of the right column with a single empty bullet point.  Some projects I found without links or title there- and thus *may* be affected by this bug- are:
Wear a Cause - Personas for Topics | Drumbeat
https://www.drumbeat.org/project/wear-cause-personas-topics
GAP | Drumbeat
https://www.drumbeat.org/project/gap
Ode (O-dee) | Drumbeat
https://www.drumbeat.org/project/ode-o-dee

Reproducible: Always

Steps to Reproduce:
View page
Actual Results:  
No links in right hand column.

Expected Results:  
Two sets of links in right hand column: 'Next Steps' links above profile picture and 'Links and other useful stuff' ones below.

Updated

8 years ago
Assignee: nobody → paulbooker

Comment 1

8 years ago
I think everything is working here (although see Observations)

I created the following group ..

http://www.drumbeat.org/project/test-project-paulbooker-ordinary-user-site-please-ignore

.. which agrees with your expected results.

Observation: 
when i created a feed item when there were now link items it created the links block with a bullet point and no title. 

Comments:
Adding "Next steps" & "Links and other useful stuff" items is optional

Best,
-- 
Paul Booker
Mozilla Contributor & [Open Web / Federated Social Web] advocate at Appcoast
Email : paulbooker@ilovetheopenweb.org
@paulbooker : http://mozilla.status.net/paulbooker
(Reporter)

Comment 2

8 years ago
Hi Paul,

Thanks for checking this out.  On my project page I created links under both "Next steps" & "Links and other useful stuff" soon after starting the project.  On the edit page for my project they are still there as always, but they are not showing up on any of my project pages.  They used to show up just fine but disappeared somewhere around the weekend of Sept.4/5 or so if I remember correctly.  So in my case the links I entered *should* be showing, but don't.
(Reporter)

Comment 3

8 years ago
Lo and behold!  I fixed it!  I went once more to the edit page and clicked save and wow- my links reappeared!

The problem *may* have been caused by visiting the edit page and exiting without clicking on any of the action buttons on the bottom, instead clicking on the Project Home tab on the top of the page.  I don't want to break my project again, so Paul do you want to try it with your test project to see if that causes the links to disappear?

Brad

Comment 4

8 years ago
Hi Brad, 

I tried the following .. 

1. Going to the edit page , making a change and then exiting via the project home tab
2. Going to the edit page , making a change , previewing and then exiting via the project home tab

but didn't produce the problem we were looking for.

However on looking at the preview page i got the following warnings ..

 * Featured field is required.
 * Project Initiator: invalid user.

.. which will need investigating (not sure if there is bug for this)

Best,
Paul Booker
Appcoast

Comment 5

8 years ago
Sorry, I did the above with my administrative account which goes some way to explaining the warnings that i received.

I tried above two steps again but again couldn't produce the problem we were looking for.
 
However i noticed that when i went to preview page i didn't get a preview page but was again returned to the edit page with a message .. 

Your project has been created! Now edit your project details <here>.

which links to the current edit page :-( (not sure if there is bug for this)

Best,
Paul Booker
Appcoast
(Reporter)

Comment 6

8 years ago
If you want to try one more pattern, what I did was go to the edit page, make no changes, then exit the edit page by the project home tab.

Brad

Updated

8 years ago
Assignee: paulbooker → nobody
This applies to the old version of drumbeat.org, which is no longer in production. Closing. Please create a new bug if the issue exists on the new site.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

4 years ago
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.