After installing the latest AlternaTIFF plugin your PluginCheck page reports it is out of date

RESOLVED INVALID

Status

defect
RESOLVED INVALID
9 years ago
2 years ago

People

(Reporter: john, Assigned: kev)

Tracking

Details

()

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9

I noticed that AlternaTIFF was a plugin that your PluginCheck page initially reported not knowing anything about. So I went to their web site <http://www.alternatiff.com/> and, using their tools, uninstalled the earlier version I had and installed the latest version. Now your PluginCheck web site asks me to update it, and when I click on the Update button it takes me to a site to install QuickTime. If you will look at the AlternaTIFF web site you'll see that they tell one about how QuickTime has its own handler for the TIFF files that AlternaTIFF is meant to handle, and that sometimes that QuickTime handler can get in the way of the AlternaTIFF one (which is recommended by, for example, the US Patent and Trademark Office web site). I don't want to install QuickTime, preferring to use the QuickTime Alternative program for the QuickTime file formats, and I certainly don't want it interfering with AlternaTIFF. So, unless you know of some specific problem in the most recent AlternaTIFF (which I would hope you had reported to the makers of AlternaTIFF), you shouldn't complain about that plug in in your PluginCheck web page.

Reproducible: Always

Steps to Reproduce:
1. Install AlternaTIFF (version 1.9.3)
2. Go to http://www.mozilla.com/en-US/plugincheck/
3. Look at results, and then click on the Update button by the AlternaTIFF plugin
Actual Results:  
You'll be taken to the QuickTime installation page.

Expected Results:  
I expected to be taken the AlternaTIFF installation page...or actually since I already had the latest version, I expected to see a green button on the PluginCheck web page.

Feel free to email me (at john@agoodman.com) or call me (at 714-537-6400) if you wish to discuss this further. Or just contact the folks at Medical Informatics
Engineering <http://www.mieweb.com/> and discuss it with them.
stephend: Not sure where this should be filed but should be moved from Core->Plugins - can you help it find a better home?
Component: Plug-ins → plugins.mozilla.org
Product: Core → Websites
QA Contact: plugins → plugins-mozilla-org
(In reply to comment #1)
> stephend: Not sure where this should be filed but should be moved from
> Core->Plugins - can you help it find a better home?

Done: -> websites / plugins.mozilla.org
Tested on 2nd. March 2011, the problem still exists. Note that AlternaTIFF is used by one of the leading family history sites in the UK (Origins - http://www.origins.net/ ).

Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14

AlternaTIFF version: 2.0.0.2

Further information: see http://www.alternatiff.com/ for the product.

Required: Either list the plugin as "Unknown", or include it in the list of supported plugins. It makes no sense at all to send people to Apple's QuickTime site (which doesn't provide the required functionality anyway).
The reason why you're getting referenced to Apple is that the Alternatiff product represents itself as "Quicktime Compatible" in its product name. Why it would do that I'm not sure, as it only renders tiff images, and is not a QT replacement. Because of this, it hits the regex that we use to detect the various iterations of the QuickTime plugins.

I'm not comfortable adding an exclusion for the AlternaTIFF plugin, but will discuss with the dev group.
Assignee: nobody → kev
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Thank you for your reply. I've e-mailed AlternaTIFF about the problem and I'll post their reply here when I receive it.
Here's the reply from AlternaTIFF:

=========================================================================
Charles Fuller wrote:
> Hello,
>
> The Mozilla Plugin Checker (see
> https://www.mozilla.com/en-US/plugincheck/ ) has a problem handling the
> AlternaTIFF plugin correctly. The problem is described on this page -
> https://bugzilla.mozilla.org/show_bug.cgi?id=594677
>
> Please could you possibly:
> - Either submit the definition of the plugin to the Mozilla "Plugin
> Check" team so that people are reminded when new versions are available.
> (This does not seem to require much time and effort.)

No promises, but I'll ask the decision-makers here if they want to start doing that.


> - Or change the "Product Name" associated with the file npzzatif.dll so
> that the text "(QuickTime compatible)" does not appear.

We will probably remove the QuickTime spoofing in the next version. We believe the Google Chrome defect that forced us to do that has since been fixed (and few people use old versions of Chrome).


>
> Any help you can give on this would help the less computer-literate
> users of your product. (The AlternaTIFF plugin is required by one of the
> major UK family history web-sites, http://www.origins.net/ , so there
> are a large number of such people.)
>
> Thanks,
> Charles Fuller.


-- 
JES / Medical Informatics Engineering, Inc. 

=========================================================================

It looks like MIE will make changes to solve the problem.
Marking invalid given current state of plugins and age of this bug
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.