Closed Bug 594685 Opened 10 years ago Closed 8 years ago

Error when updating from beta 4 to 5. Session with tabs lost (panorama too)

Categories

(Firefox :: Session Restore, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: linobarreca, Unassigned)

Details

(Whiteboard: [closeme 2011-10-26])

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Win64; x64; Trident/4.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E; InfoPath.3; Tablet PC 2.0)
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

Updated from b4 to b5:
Everything went ok.
I clicked the button "Restart firefox"
It shut down and restarted automatically..
Compatibility check for extensions (everything ok)

Then a messagebox:

L'operazione non può essere completata a causa di un errore interno. Una comunicazione di rete sicura non è stata chiusa correttamente.

meaning something similar to:
Unable to complete the operation because of an internal error.
A safe network communication has not been closed properly.

if I click on "OK" the window opens up.
with all the tabs I had before but WHITE without anything in it (all "new tab")

Reproducible: Always

Steps to Reproduce:
I don't know. I had lots of tabs open (some HTTPS)
Actual Results:  
Session LOST.
All tabs addresses / organization (with PANORAMA) ARE LOST!!!!
They are all blank (new tab)
Noreover the browser won't surf if I use that tabs.
If I type something into the address bar nothing happens.
I have to open new tab and use that.

Expected Results:  
Update as usual.

I had sync properly installed/configured and already synced on this computer (yesterday)
Is there a way to restore my session from sync?(I need all that tabs and I don't remember their address)

I need a way to tell sync "ignore actually opened windows, don't sync them with the server, restore everything from last synced status on this computer"

Please help.
screenshots available on request.
(In reply to comment #0)
> Is there a way to restore my session from sync?(I need all that tabs and I
> don't remember their address)

Not any way that I know of.

So long as you haven't restarted Firefox, you should be able to get your session back...

Find your profile directory (http://support.mozilla.com/en-US/kb/Profiles#How_to_find_your_profile) and make a copy of sessionstore.bak (and .js). Quit Firefox, and copy your saved sessionstore.bak to sessionstore.js in your profile.
I can't, it overwrited both them all.
.BAK's time is 9.15 am (764KB)
.JS's time is 9.42 am (1467KB)

I opened the .bak with notepad and I saw it has already lost my second window's session (I had two windows opened at the time of update)
If I restore the .BAK the second window is lost and the remaining window already has the problem.

I can restore the .JS with windows' "Previous versions of files". I found an useful backup to yesterday.
I'll let you know.

Thank you.
Ok... I used the version saved automatically from windows 7 yesterday and I was able to get _almost_ everything back.
I restored the .JS (making a backup of the damaged one just in case I need it).
I opened firefox and it said the classical message "oops..something wrong happened... want to restore your session?" with the complete list (up to yesterday) of windows/tabs.
THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU  PAUL!!!!
(and thanks to Bill Gates too :D for its new feature on win 7)

..now..
How can the problem be tracked and avoided for the future?
The message makes me think it could be related to the new HSTS implementation.

Moreover an option to Sync "Restore my last syncronized session" would be GREAT when there are problems like this.
(In reply to Lino Barreca from comment #0)
> Unable to complete the operation because of an internal error.
> A safe network communication has not been closed properly.

Lino, before we dig further, can you still reproduce this when using a current version of Firefox?
Whiteboard: [closeme 2011-10-26]
Well...it was an ooooold problem I didn't have it in newer versions :))
I'm currently using 8 beta and I have another problem when exiting the "porn..ehm..gift mode" :P (tabs are not restored correctly in their group and I have to reorganize them to the appropriate groups left empty. I don't know if someone already reported this but I'm almost sure someone did.)

But for this one I think you can close the bug...it has been solved some-way :))
Thank you.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.