Status

P3
normal
VERIFIED WONTFIX
18 years ago
4 years ago

People

(Reporter: atle.lie.ellefsen, Assigned: evangelism)

Tracking

Details

(Reporter)

Description

18 years ago
I'm developing a site, and I'm using a dropdown menu with submenues. The
dropdownmenu dosn't show at all (it's declared as hidden). works fine with NS
4.76, 4.7, 4.5 and MSIE 5.0, 5.5 but not in NS 6.0 PR 2.

Another thing are problems with (CSS) absolute positing. problems there as well.
There is a picture in the bg of a table, but the values of the position doesn't
match the values in NS 4.76, 4.7, 4.5 and MSIE 5.0, 5.5 but not in NS 6.0 PR 2.


----- code example ------


<html>
<head>
<link type="text/css" href="../doorstyle.css" rel="stylesheet">
	<title>bankmain</title>
</head>
<script language="JavaScript">
<!--
function MM_findObj(n, d) { //v3.0
  var p,i,x;  if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
    d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
  if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++)
x=d.forms[i][n];
  for(i=0;!x&&d.layers&&i<d.layers.length;i++)
x=MM_findObj(n,d.layers[i].document); return x;
}

function MM_showHideLayers() { //v3.0
  var i,p,v,obj,args=MM_showHideLayers.arguments;
  for (i=0; i<(args.length-2); i+=3) if ((obj=MM_findObj(args[i]))!=null) {
v=args[i+2];
    if (obj.style) { obj=obj.style; v=(v=='show')?'visible':(v='hide')?'hidden':v; }
    obj.visibility=v; }
}

function MM_preloadImages() { //v3.0
  var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
    var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
    if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
}

function MM_swapImgRestore() { //v3.0
  var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a[i])&&x.oSrc;i++)
x.src=x.oSrc;
}

function MM_swapImage() { //v3.0
  var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array;
for(i=0;i<(a.length-2);i+=3)
   if ((x=MM_findObj(a[i]))!=null){document.MM_sr[j++]=x; if(!x.oSrc)
x.oSrc=x.src; x.src=a[i+2];}
}
//-->
</script>
<body background="../images/background2.gif" bgcolor="#FFFFFF" marginheight="0"
marginwidth="0" leftmargin="0" topmargin="0">

<div id="banklayer" style="position:absolute; width:51; height:20; z-index:10;
top: 0px; left: 28px"><a href="#"
onMouseOver="MM_showHideLayers('s01','','show')"
onMouseOut="MM_showHideLayers('s01','','hide')"><img
src="../images/banken_1.gif" width="51" height="20" border="0" alt=""></a></div>

<!-- submenu 01 -->
<div id="s01" style="position:absolute; width:144; height:56; z-index:10; top:
20px; left: 24px; visibility: hidden">
  <table width="144" border="0" cellspacing="0" cellpadding="0">
<tr>
	  <td><a href="b_s01.html"
onMouseOut="MM_swapImgRestore();MM_showHideLayers('s01','','hide')"
onMouseOver="MM_swapImage('b_s01','','buttons/b_s01_on.gif',0);MM_showHideLayers('s01','','show')"><img
src="buttons/b_s01_off.gif" width="144" height="14" name="b_s01"
border="0"></a></td>
</tr>
<tr>
      <td><a href="b_s02.html"
onMouseOut="MM_swapImgRestore();MM_showHideLayers('s01','','hide')"
onMouseOver="MM_swapImage('b_s02','','buttons/b_s02_on.gif',0);MM_showHideLayers('s01','','show')"><img
src="buttons/b_s02_off.gif" width="144" height="14" name="b_s02"
border="0"></a></td>
</tr>
<tr>
      <td><a href="b_s03.html"
onMouseOut="MM_swapImgRestore();MM_showHideLayers('s01','','hide')"
onMouseOver="MM_swapImage('b_s03','','buttons/b_s03_on.gif',0);MM_showHideLayers('s01','','show')"><img
src="buttons/b_s03_off.gif" width="144" height="14" name="b_s03"
border="0"></a></td>
</tr>
<tr>
	  <td><a href="b_s04.html"
onMouseOut="MM_swapImgRestore();MM_showHideLayers('s01','','hide')"
onMouseOver="MM_swapImage('b_s04','','buttons/b_s04_on.gif',0);MM_showHideLayers('s01','','show')"><img
src="buttons/b_s04_off.gif" width="144" height="14" name="b_s04"
border="0"></a></td>
</tr>
<!-- <tr>
	  <td><a href="b_s05.html"
onMouseOut="MM_swapImgRestore();MM_showHideLayers('s01','','hide')"
onMouseOver="MM_swapImage('b_s05','','buttons/b_s05_on.gif',0);MM_showHideLayers('s01','','show')"><img
src="buttons/b_s05_off.gif" width="144" height="14" name="b_s05"
border="0"></a></td>
</tr>
<tr>
	  <td><a href="b_s06.html"
onMouseOut="MM_swapImgRestore();MM_showHideLayers('s01','','hide')"
onMouseOver="MM_swapImage('b_s06','','buttons/b_s06_on.gif',0);MM_showHideLayers('s01','','show')"><img
src="buttons/b_s06_off.gif" width="144" height="14" name="b_s06"
border="0"></a></td>
</tr> -->
<tr>
	  <td><a href="b_s07.html"
onMouseOut="MM_swapImgRestore();MM_showHideLayers('s01','','hide')"
onMouseOver="MM_swapImage('b_s07','','buttons/b_s07_on.gif',0);MM_showHideLayers('s01','','show')"><img
src="buttons/b_s07_off.gif" width="144" height="14" name="b_s07"
border="0"></a></td>
</tr>
</table>
</div>

<!-- Bakgrunnsbilde og text -->
<img src="images/pix.gif" width="10" height="16" border="0" alt="">
<table cellspacing="0" cellpadding="0" border="0" width="768">
<tr>
	<td rowspan="4" width="28"><img src="images/pix.gif" width="28" height="1"
border="0" alt=""></td>
    <td colspan="3" valign="top" class="rod-b" width="740"

Comment 1

18 years ago
*** Bug 59474 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
*** Bug 59475 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
*** Bug 59476 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
*** Bug 59478 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Reporter, can you add your code example as an attachment, as the end of it is
chopped of in the Bug Description.
Also please file one bug per issue.  Each bug should have as simple a testcase
as possible demonstrating that bug.

Finally, NS 6.0 PR2 is too old to use for filing bugs on Mozilla.  It's probably
best to use at least M18 (which was after NS 6 PR3, I think).
Actually, significant changes have been made after M18. Using the latest
nightlies is the best way to find out what works.

Comment 8

18 years ago
reporter: easy, you are using .layers ... and that is not a w3c.org
recommendation, and therefore, netscape/mozilla have decided to drop it from v6
and on. You should use divs instead.  evang!
Assignee: asa → blakeross
Status: UNCONFIRMED → NEW
Component: Browser-General → Evangelism
Ever confirmed: true
QA Contact: doronr → zach

Comment 9

18 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Hardware: PC → All

Comment 10

18 years ago
Could the owner please close this bug - if applicable.(and I'm thinking it might
be applicable...   ;-)
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 11

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 12

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.