Closed Bug 594736 Opened 12 years ago Closed 8 years ago

imageshack.com - cannot upload photo from device using Firefox for Android

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set
normal

Tracking

(fennec-)

RESOLVED WORKSFORME
Tracking Status
fennec - ---

People

(Reporter: ioana.chiorean, Unassigned)

References

()

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b5) Gecko/20100101 Firefox/4.0b5
Build Identifier: Mozilla /5.0 (Maemo;Linux armv7l; rv:2.0b6pre)Gecko/20100909 Firefox/4.0b6pre Fennec /2.0b1pre

Cannot upload photo from Nokia N900 Maemo5 QT build 20100909011130

Reproducible: Always

Steps to Reproduce:
1. enter fennec to http://www.imageshack.com/

Actual Results:  
- there should be a browse button near the empty field under upload

Expected Results:  
- the empty field under upload is longer than usual, no browse button
OS: Other → Maemo
Hardware: Other → ARM
Summary: [QT] can not upload photo → [QT] can not upload photo from device
Attached image screenshot
for facebook.com the button is present but no action is made tapping it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
tracking-fennec: --- → ?
Flags: in-litmus+
Assignee: nobody → doug.turner
tracking-fennec: ? → 2.0b2+
is this still an issue?
Whiteboard: resolveme 2010-09-30
The display in imageshack.com is still the one as in attached screenshot above ("Browse" button is not visible):
device: nokia N900
buildID: Mozilla /5.0 (Maemo;Linux armv7l; rv:2.0b7pre)Gecko/20100924
Firefox/4.0b7pre Fennec /2.0b1pre
Attached image Screenshot
for facebook.com, "Browse" button opens a dialog like in attached screenshot
so, maybe the width of that element is all off.

and it looks like their non-flash fallback uses a fixed length that is basically bigger than what it should be.

Maybe this should be a evangelism bug, and it is clearly not blocking fennec product.
tracking-fennec: 2.0b2+ → 2.0-
I see this on builds (nexus one and samsung vibrant):

Mozilla/5.0 (Android; Linux armv7l; rv:2.0b7pre) Gecko/20101006
Firefox/4.0b7pre Fennec/4.0b1


I think this should block Fennec 2.0 and I'm not sure why it was marked as 2.0-
tracking-fennec: 2.0- → ?
OS: Maemo → All
Hardware: ARM → All
Summary: [QT] can not upload photo from device → Can not upload photo from device
Whiteboard: resolveme 2010-09-30
Hey Aakash, please read my comment 7.
tracking-fennec: ? → 2.0-
Ah whoops.
Assignee: doug.turner → nobody
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
Moving this to evangelism.
Assignee: nobody → english-us
Status: RESOLVED → REOPENED
Component: General → English US
Flags: in-litmus+
Product: Fennec → Tech Evangelism
QA Contact: general → english-us
Resolution: INVALID → ---
Version: Trunk → unspecified
If more than one site needs to fix things, there need to be separate TE bugs for each site that's broken.
Summary: Can not upload photo from device → imageshack.com - cannot upload photo from device using Fennec
This issue is still reproducing on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:2.0b13pre)Gecko/201100321
Firefox/4.0b13pre Fennec /4.1a1pre
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1

When I tap on the Browse button, a list with helper apps will be displayed after several seconds. If I tap on the helper app which will open my Gallery Photos, my screen will turn to black and will persist like this for about a minute. Then if I choose a pic to upload, the screen will turn again to black an remains like that for minutes or even more. Also the Android system is frozen and any tap on System Buttons (Back, Menu etc.) will open the following message:
"Sorry!
Activity Fennec (in application Fennec) is not respondig.
Force close (button) | Wait (button)"
The only way to unfreeze the system is to tap on Force close.

I tried to reproduce this on http://www.imageshack.com/ and http://gickr.com
Assignee: english-us → nobody
Component: English US → Mobile
OS: All → Android
Hardware: All → ARM
Summary: imageshack.com - cannot upload photo from device using Fennec → imageshack.com - cannot upload photo from device using Firefox for Android
Still an issue? Sorry, I don't have a test acct here.
Flags: needinfo?(nicolae.cristian2010)
A new version is available, compared to the previous screenshot. I tested from my Nexus 7 Android 4.4 and Firefox 32.0.3, everything is OK, I am registered, and I could send a picture to the site
Thank you!
Status: REOPENED → RESOLVED
Closed: 12 years ago8 years ago
Flags: needinfo?(nicolae.cristian2010)
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.