regression causes video not to play on dailymotion

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
8 years ago
5 years ago

People

(Reporter: Reuben, Unassigned)

Tracking

4.0 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b5) Gecko/20100101 Firefox/4.0b5
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

A regression in Firefox 4.0 Beta 5 causes video on dailymotion to load indefinitely and never play.

Reproducible: Always
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100909 Firefox/4.0b6pre

Confirming, I can't get any videos to play in safe mode or a new profile, but in a clean profile on 4.0b4 videos play fine.
I don't get any loading animation, its just the preview screenshot with unresponsive player controls.

Not sure what is wrong, nothing in the error console.

I also tried using User Agent Switcher to use the 4.0b4 UA but it didn't work, so its not a UA sniffing problem.
It looks like the DailyMotion HTML5 player has undergone an upgrade.

After opting into the HTML5 beta that now appears when you go to the referenced URL, HTML5 video plays fine for me.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100925 Firefox/4.0b7pre

Updated

7 years ago
Version: unspecified → 4.0 Branch
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.