[PP]demo blocker -Frequent resizing of window causes apprunner to stop drawing

VERIFIED FIXED in M6

Status

()

Core
Event Handling
P1
blocker
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: Pierre Saslawsky)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I've seen (in debug builds, couldn't repro the one time i tried with optimized)
that if you resize the window a lot with a web page (like abcnews or apple.com),
eventually you can catch it so that the rendering context gets freaked out and
you get tons of asserts that mPort is null in nsRenderingContextMac.h.

Once you get this, controls draw (scrollbars, form elements), but nothing else
redraws in the window.

I've been able to dup this both on my machine and sdagleys by playing with it for
a while (quickly resizing the window over and over again). It's much more easily
reproduceable on my machine, for some reason.

Bumped up to blocker because we this may be a demo blocker for an important
conference.
(Reporter)

Updated

19 years ago
Group: netscapeconfidential?
Priority: P3 → P1
(Reporter)

Comment 1

19 years ago
marking P1, and Netscape Confidential.
(Reporter)

Comment 2

19 years ago
adding dagley and simon to cc list.

If Jobs gives the goahead, we will want to use the current build for demos at
WWDC. The fact that we may be doing a demo is both Apple and NSCP confidential,
btw, which is why this bug is marked that way.

Given the regularity with which i can repro this bug with my Carbon build, it may
be more easily tickled by that, hence we'll probably have problems with the demo
as well, and that would be bad.

If Jobs cuts the demo, this is no longer such a high priority, but we should get
this looked at ASAP since the keynote is on Monday.
(Reporter)

Comment 3

19 years ago
I can most frequently dup this bug by going to www.dvdresource.com, resizing the
window a bit, then www.apple.com and then resizing until it happens. It seems to
help repro it when I start resizing before the page is totally loaded, but there
is no set pattern, unfortunately.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

19 years ago
I saw it too.
Accepting bug.

Updated

19 years ago
Summary: Frequent resizing of window causes apprunner to stop drawing → [PP]Frequent resizing of window causes apprunner to stop drawing

Updated

19 years ago
Summary: [PP]Frequent resizing of window causes apprunner to stop drawing → [PP]demo blocker -Frequent resizing of window causes apprunner to stop drawing
(Reporter)

Updated

19 years ago
Group: netscapeconfidential?
(Reporter)

Comment 5

19 years ago
since the demo came and went and it's all now public, making this open to the
general public again.

Updated

19 years ago
Component: Apprunner → Event Handling
QA Contact: 3853 → 4137
(Assignee)

Updated

19 years ago
Target Milestone: M6
(Assignee)

Comment 6

19 years ago
*** Bug 6016 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

19 years ago
pierre, what was the fix? I'm curious.
(Assignee)

Comment 8

19 years ago
An out-of-mem error was not correctly reported in nsRenderingContextMac. I also
fixed the ViewManager so that it uses offscreen drawing again when the memory is
available (otherwise you had to go to another page to get offscreen drawing
again).

On my machine and with the current debug build, the problem could be reproduced
with a single resize when making the window cover the entire screen (1152 x 870,
millions of colors).

I still have to implement a smarter memory allocation for offscreen buffers (bug
#3412). It should be fairly straightforward but I did not want to take chances
for M6.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
I can't make apprunner crash after resizing way too often at dvdresource.com and
apple.com. (And as far as the demo goes, apple.com isn't currently rendering
correctly. Hope that went better at the demo...) Build 1999051812, Mac OS 8.6.
You need to log in before you can comment on or make changes to this bug.