Closed Bug 595003 Opened 10 years ago Closed 10 years ago

Clicking on download notification with awesome screen open moves user back to browser window

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: aakashd, Assigned: wesj)

Details

Attachments

(1 file)

Build Id:
Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b6pre) Gecko/20100909 Namoroka/4.0b6pre Fennec/2.0b1pre

Steps to Reproduce:
1. Start a download
2. Click on the url bar to open the awesome screen
3. Slide open the notifications window 
4. Click on the "downloading notification"

Actual Results:
The user is moved to the browser window

Expected Results:
The user should be moved to the download manager
tracking-fennec: --- → ?
Duplicate of this bug: 595632
Assignee: nobody → wjohnston
tracking-fennec: ? → 2.0b2+
Attached patch PatchSplinter Review
This is an order of operations problem. The activePanel setter calls BrowserUI.showToolbar(false); which calls hidePanel and undoes everything we did to show it.
Attachment #477352 - Flags: review?(mark.finkle)
Attachment #477352 - Attachment mime type: application/octet-stream → text/plain
Attachment #477352 - Attachment is patch: true
Comment on attachment 477352 [details] [diff] [review]
Patch

Seems safe enough. I don't think we put the code in the middle on purpose to begin with.
Attachment #477352 - Flags: review?(mark.finkle) → review+
Whiteboard: [fennec-checkin-postb1]
pushed:
http://hg.mozilla.org/mobile-browser/rev/f2ec842f36f8
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [fennec-checkin-postb1]
verified FIXED on build:

Mozilla/5.0 (Android; Linux armv71; rv:2.0b6pre) Gecko/20100930 Namoroka/4.0b7pre Fennec/4.0b1pre
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
Flags: in-litmus? → in-litmus?(ayanshah62)
Litmus test case - 

https://litmus.mozilla.org/show_test.cgi?id=12701
Flags: in-litmus?(ayanshah62) → in-litmus+
You need to log in before you can comment on or make changes to this bug.