CSS Regression :first-letter falls down

VERIFIED DUPLICATE of bug 594303

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 594303
7 years ago
7 years ago

People

(Reporter: Bamm Gabriana, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 473893 [details]
How it looks in Firefox 4.0 Beta 4 and Beta 5.

Firefox 4.0 Beta 4 and Beta 5.

In my web site
http://www.pyxis.astronomy.com.ph/

In the home page the letter P is placed way below where it should be. Funny is that, upon loading the page, it first gets rendered in the right place then suddenly falls down to the wrong place. Some other pages in the site show the same problem.

I believe there is nothing wrong in my CSS. It works in all previous versions of Firefox as well as in Opera, Safari, and Chrome.

It also works in Firefox 4.0 Beta 3.
(Reporter)

Comment 1

7 years ago
Created attachment 473896 [details]
How it looks in Firefox 3.6.x.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594303
(Reporter)

Comment 3

7 years ago
philippe, bug 594303 does seem to be related, but it only talks about the "clear" property not working.

I do not use "clear" in my CSS, but the bug in :first-letter still manifests.

Could it be possible to pinpoint which patch broke this?

Comment 4

7 years ago
The testcase in bug 594303 doesn't use clear either. The bug summary points to the visible (incorrect) behaviour. Just as in your case, the ::first-letter drops below the floated block on the right (giving the impression of 'clearing' that floated block).

> Could it be possible to pinpoint which patch broke this?

you could verify the regression range in bug 594303 comment2, using builds between August 5 and 6 (I think)
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2010/08/
(Reporter)

Comment 5

7 years ago
After thinking about it, I now agree that my bug report is a duplicate of the
one you mentioned. I am confirming the dupe and will henceforth follow the
other bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.