Closed Bug 595170 Opened 9 years ago Closed 9 years ago

Some single line inputs break the form filler tool

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: kbrosnan, Assigned: vingtetun)

References

()

Details

(Whiteboard: [Fennec2.0bTestday])

Attachments

(3 files, 1 obsolete file)

I loaded the enter bug page in Bugzilla and tried to tab through the form using the form filler buttons. When I got to the single line summary field the form filler took up most of the page.
Attached image screen shot of issue
Whiteboard: [Fennec2.0bTestday]
tracking-fennec: --- → 2.0b2+
I think something went wrong in the zooming code and block your UI but I'm not able to reproduce it. :(
Are you able to reproduce it and if yes could you look in the error console what happened and paste it here?

You could enable the error console by turning the pref:
browser.console.showInPanel to true (dixit http://starkravingfinkle.org/blog/2009/06/embedding-the-error-console-in-fennec/)
and you can see errors happening in chrome by turning the pref  javascript.options.showInConsole to true (dixit https://developer.mozilla.org/en/Setting_up_extension_development_environment#Development_preferences)

This could be really helpful to help us have a better idea of what fails internally and find a way to reproduce on my device to debug it.
Typed by hand. But should be correct. Will upload screen shot of the error console.

Error: uncaught exception: [Exception... "'[JavaScript Error: "null has no properties" {file: "file:///home/kevin/Desktop/fennec/components/FormAutoComplete.js" line: 152}]' when calling method: [nsIFormAutoComplete::autoCompleteSearch]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: chrome://browser/content/browser-ui.js :: _formHelperGetAutocompleteSuggestions :: line 1829" data: yes]
Attached patch Patch (obsolete) — Splinter Review
(In reply to comment #4)
> Created attachment 474545 [details]
> Screen shot of the fennec error console

Thanks for the screenshot and for the console dump.

I suspect you have browser.formfill.enable set up to false in about:config?

Mark, the only way to have null for this case seems to be to have this pref turn to false.
The attached patch resolved the problem by checking "normal" before looking for a property on it.
Attachment #474564 - Flags: review?(mark.finkle)
(In reply to comment #5)
> I suspect you have browser.formfill.enable set up to false in about:config?
Correct, that explains why a new profile prevented the issue from showing.
Comment on attachment 474564 [details] [diff] [review]
Patch

Perhaps we should be checking the pref too and returning early, without doing any contact lookup.
(In reply to comment #7)
> Comment on attachment 474564 [details] [diff] [review]
> Patch
> 
> Perhaps we should be checking the pref too and returning early, without doing
> any contact lookup.

Obviously you're right, there is no need for this unuseful work in this case.
Attached patch Patch v0.2Splinter Review
The patch does what Mark suggests.
Assignee: nobody → 21
Attachment #474564 - Attachment is obsolete: true
Attachment #474641 - Flags: review?(mark.finkle)
Attachment #474564 - Flags: review?(mark.finkle)
Comment on attachment 474641 [details] [diff] [review]
Patch v0.2

Put the check above the LOG statement. I think that makes more sense.
Attachment #474641 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/15511aa0d39e
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on build:
Mozilla/5.0 (maemol Linux armv7l; rv:2.0b7pre) Gecko/20101029 Firefox/4.0b8pre Fennec/4.0b2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.