Web Console filter should not be case sensitive

VERIFIED FIXED

Status

()

Firefox
Developer Tools
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: msucan, Assigned: rc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [Web-Console-Testday])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Currently the filter finds only exact matches, which is far too strict, in terms of English searches. We are not searching for JavaScript code, or stuff like that. We are searching through human-readable output, hence I believe we should not be case-sensitive about.

Comment 1

7 years ago
I agree that case insensitivity would be better.
Blocks: 594225
(Assignee)

Comment 2

7 years ago
taking, despite lack of blocking status.
Assignee: nobody → rcampbell
Status: NEW → ASSIGNED
(Assignee)

Comment 3

7 years ago
requesting blocking for B7.
blocking2.0: --- → ?
(Assignee)

Comment 4

7 years ago
Created attachment 474759 [details] [diff] [review]
[checked-in] Filter search case insensitive
Attachment #474759 - Flags: review?
(Assignee)

Comment 5

7 years ago
Comment on attachment 474759 [details] [diff] [review]
[checked-in] Filter search case insensitive

have to use this strange translate() function as we don't seem to support the lower-case() xpath2.0 function.

See bug 398389.
Attachment #474759 - Flags: review? → review?(dietrich)
(In reply to comment #5)
> Comment on attachment 474759 [details] [diff] [review]
> Filter search case insensitive
> 
> have to use this strange translate() function as we don't seem to support the
> lower-case() xpath2.0 function.
> 
> See bug 398389.

Jonas says that lower-case() may be implementable. Fingers crossed!
Duplicate of this bug: 596290
Would be really nice to have, but I don't think it blocks
blocking2.0: ? → -
Attachment #474759 - Flags: review?(dietrich) → review+
(Assignee)

Updated

7 years ago
Attachment #474759 - Flags: approval2.0?
(Assignee)

Comment 9

7 years ago
probably not a blocker but would like approval for landing. Improves searching experience.
Comment on attachment 474759 [details] [diff] [review]
[checked-in] Filter search case insensitive

One line fix for improved usability with 8 lines of test? Okay!
Attachment #474759 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 11

7 years ago
Comment on attachment 474759 [details] [diff] [review]
[checked-in] Filter search case insensitive

http://hg.mozilla.org/mozilla-central/rev/34f833a4b7d0
Attachment #474759 - Attachment description: Filter search case insensitive → [checked-in] Filter search case insensitive
(Assignee)

Comment 12

7 years ago
(In reply to comment #10)
> Comment on attachment 474759 [details] [diff] [review]
> [checked-in] Filter search case insensitive
> 
> One line fix for improved usability with 8 lines of test? Okay!

aces! Thank you!
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Status: RESOLVED → VERIFIED
Whiteboard: [Web-Console-Testday]
You need to log in before you can comment on or make changes to this bug.