Long profile name leads to no Sidebar content, other issues

RESOLVED WONTFIX

Status

Core Graveyard
Profile: BackEnd
P3
normal
RESOLVED WONTFIX
18 years ago
2 years ago

People

(Reporter: cpratt, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
Future
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Build ID: 20001108 (NS6 branch)
Platform: Mac OS 9

To reproduce:
- Launch the profile manager
- Create a profile with a long name (I'm guessing more than 32 chars)
- After activation, the My Sidebar area is blank
- Tabs | Customize Sidebar gives a window with no available tabs (it's all 
blank)
- If you quit and relaunch Netscape 6, the profile you just created will have 
disappeared
shrir, could this be a result of bug 58099?

Comment 2

18 years ago
58099 is (was) about blank 'what's related' and that is fixed.  

Comment 3

18 years ago
reassinging to racham.
Assignee: putterman → racham

Comment 4

18 years ago
It will be nice if we have a feature in nsIFile that tells us the platform
specific limitations so that we can enforce the check from the frontend...

Comment 5

18 years ago
Doing a mass reassign to Conrad Carlen.

Conrad is going address all current and upcoming profile manager issues. Please
do not hesitate to involve me in any of the issues.
Assignee: racham → ccarlen
(Assignee)

Comment 6

18 years ago
Yikes, it sure does. The front end needs code so the user knows the name is too
long and the backend should ensure this as well. 
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.8
(Assignee)

Comment 7

18 years ago
Created attachment 21612 [details] [diff] [review]
Fix for front-end
(Assignee)

Comment 8

18 years ago
The above patch makes the front-end limit the profile name length. Since we
don't have a good XP way to find this limit, I just used navigator.platform.

Comment 9

18 years ago
we should capture other OS's too (at least linux and windows).
(Assignee)

Comment 10

18 years ago
-> mozilla 0.9
Target Milestone: mozilla0.8 → mozilla0.9
(Assignee)

Comment 11

17 years ago
-> 0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1
(Assignee)

Comment 12

17 years ago
-> future. It's an edge case.
Target Milestone: mozilla0.9.1 → Future

Updated

16 years ago
Keywords: mozilla1.1

Updated

15 years ago
Keywords: mozilla1.1
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Comment 14

14 years ago
Mac Classic RIP
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.