list should filter invalid values

RESOLVED DUPLICATE of bug 582248

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 582248
8 years ago
8 years ago

People

(Reporter: mounir, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
The specifications ask us to filter invalid values showed by the list attribute. The current implementation do not do that.
IIRC, Jonas thinks we should not do that because authors will not be able to put in the list beginnings of value like area codes for telephone numbers.
IMO, we should do that because I don't think list should be used to provide a part of a value and selecting an invalid value might be confusing for the user (form being un-submittable because of that). However, we might want to not filter the values if the form element has novalidate attribute. But that could be weird because of the un-consistency.
(Reporter)

Comment 1

8 years ago
I think this should block final or betaN so we do not ship a buggy feature.
blocking2.0: --- → ?
(Reporter)

Updated

8 years ago
Blocks: 556007
(Reporter)

Comment 2

8 years ago
Damn, a bug has been open for that but not really at the appropriate place... Marking as duplicate.
No longer blocks: 344614, 556007
Status: NEW → RESOLVED
blocking2.0: ? → ---
Last Resolved: 8 years ago
Keywords: dev-doc-needed, html5
Resolution: --- → DUPLICATE
Duplicate of bug: 582248
You need to log in before you can comment on or make changes to this bug.