Closed Bug 595317 Opened 10 years ago Closed 10 years ago

Scrollbars don't appear in the details view

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla2.0b7
Tracking Status
blocking2.0 --- final+

People

(Reporter: mossop, Assigned: mossop)

References

Details

(Keywords: regression)

Attachments

(1 file)

This worked when the details view was first updated but now it seems something has regressed and scrolling is broken in the details view again.
blocking2.0: --- → final+
Dave, you mean one of our patches broke it or a widget issue?
I have no idea at this point
I see scrollbars in the details view. How do you reproduce?
Regressed between 10090103 and 10090203.

PASS: http://hg.mozilla.org/mozilla-central/rev/f47972d05473
FAIL: http://hg.mozilla.org/mozilla-central/rev/dc2939f2640d

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f47972d05473&tochange=dc2939f2640d

Regression from bug 562902.

On Windows the scrollbars appear but are cut-off on the right side. Which has the same effect as when they will not visible, you can't use them.
Blocks: 562902
OS: Mac OS X → All
Hardware: x86 → All
That's interesting because I distinctly remember the scrollbars working when I landed that (see bug 562902 comment 41).
What about bug 579276? Why was that ruled out as a possible regressor? (I'm sure roc will be able to comment on the feasibility of that, but I think that may be possible...)
(In reply to comment #6)
Hrm, scratch that. It was backed out...
Blocks: 592705
Blocks: 597088
Assignee: nobody → dtownsend
Attached patch patch rev 1Splinter Review
One scrollbox to rule them all...

I hadn't looked closely enough at this. There were a total of 3 scrollable areas nested in the detail view which is just asking for trouble. This just makes the whole pane scrollable and removes overflow from the other bits. Tested on all 3 platforms and it seems to behave itself.
Attachment #477717 - Flags: review?(bmcbride)
Status: NEW → ASSIGNED
Whiteboard: [has patch][needs review Unfocused]
Comment on attachment 477717 [details] [diff] [review]
patch rev 1

Is there a reason you made the global-warning box scroll with the contents? It doesn't scroll in any other view. Not sure what should be the behaviour there, but I'm fine with it scrolling if you prefer that.
Attachment #477717 - Flags: review?(bmcbride) → review+
I think it makes more sense for the other views whee we are showing lists and it is pretty normal to have lists scroll separate to other elements, here I just decided to go with the simple single scrollbox to try to avoid any reasons why we might miss some aspect of this.
Whiteboard: [has patch][needs review Unfocused] → [has patch][needs-checkin-post-b7]
Fixed: http://hg.mozilla.org/mozilla-central/rev/0486d4990f88

Not sure this is worth a litmus test or not.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Flags: in-testsuite-
Flags: in-litmus?
Resolution: --- → FIXED
Whiteboard: [has patch][needs-checkin-post-b7]
Target Milestone: --- → mozilla2.0b8
Is this still necessary?
  /* This is necessary to fix layout issues with multi-line descriptions, see
     bug 592712*/
  outline: solid transparent;
(In reply to comment #12)
> Is this still necessary?
>   /* This is necessary to fix layout issues with multi-line descriptions, see
>      bug 592712*/
>   outline: solid transparent;

Last I checked, yes
Dave, we still underflow the right side if the window is too narrow. That pushes the vertical scrollbar out of view. Wasn't it intended to get fixed too? If not I can file a new bug.
Sorry that I have to reopen the bug. But it doesn't work consistently in the different detail panes. While for search results, get addons, and recent updates it looks good, the details pane for the other categories still doesn't show a horizontal scrollbar at all with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101008 Firefox/4.0b8pre
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #15)
> Sorry that I have to reopen the bug. But it doesn't work consistently in the
> different detail panes. While for search results, get addons, and recent
> updates it looks good, the details pane for the other categories still doesn't
> show a horizontal scrollbar at all with Mozilla/5.0 (Macintosh; Intel Mac OS X
> 10.6; rv:2.0b8pre) Gecko/20101008 Firefox/4.0b8pre

That isn't exactly what I see but I forgot there still is another problem here, we need a new bug
Ignore the last comment. This bug is fixed, I've filed bug 602895 to take care of the final global case.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Verified fixed with builds on all platforms like Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101029 Firefox/4.0b8pre
Status: RESOLVED → VERIFIED
Target Milestone: mozilla2.0b8 → mozilla2.0b7
You need to log in before you can comment on or make changes to this bug.