Wrong contents showing up in a targeted window.

VERIFIED DUPLICATE of bug 41241

Status

P3
major
VERIFIED DUPLICATE of bug 41241
18 years ago
14 years ago

People

(Reporter: tarahim, Assigned: joki)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I have been seeing this for quite a while, and I could not find a similar entry.

Goto the URL.
Type in the input area the following two lines:
>whatever
acgtacgtacgtacgt
Hit "Search" button.
In the next window, hit "Format".
Result: the content of the above URL appears in the new window.
Expected result: the result of the search is supposed to appear in the new
window.  You can get the result to appear after you hit "Format" in the first
window again.

2000110808 MTrunk.
(Reporter)

Comment 1

18 years ago
I have a hunch that this has something to do with cookies problem.
http://www.ncbi.nlm.nih.gov/entrez/query.fcgi?CMD=Index&DB=PubMed
A similar example is above URL.
You type a keyword in the text input are at the top, "Internet" works for
testing purpose, and hit Preview.
The first time you hit it, they send you a page that says there is a problem
with cookies.  Then you hit Preview again, and it works.
Changing component to cookies.
Component: Event Handling → Cookies

Comment 2

18 years ago
Tossing cookies over there.
QA Contact: lorca → tever
(Reporter)

Comment 3

18 years ago
I have noticed that Mozilla sends two requests in forms.
Those are in bug 60388 and bug 41241.
Is this bug a dupe of bug 41241?
The form at the URL uses POST.

Comment 4

18 years ago
This is not cookies but I don't know what it should be.  Changing component to 
browser-general
Component: Cookies → Browser-General

Comment 5

18 years ago
Thanks Hirata, it looks like you are right.  The original bug report here is a
dup of 41241.

Bug 60388 is not directly related, but looks like it is the remaining part of
bug 27006.  I've included a comment there to that effect.  To verify if this is
the case or not, we need a testcase or the reporter to look at their existing
testcase.

The problems with
http://www.ncbi.nlm.nih.gov/entrez/query.fcgi?CMD=Index&DB=PubMed are not
related because they are not the result of double submits.  That should be filed
as a separate bug, though I strongly suspect it is something wrong with the
server side.  It works fine for me every time after the first time I post, and
even that one shows up on the list of recent searches. ???



*** This bug has been marked as a duplicate of 41241 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.