caption buttons are not rendered correctly, and Aero missing.

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: pal-moz, Unassigned)

Tracking

(Depends on: 1 bug, {regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 474460 [details]
screenshot

build : http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1284238012/

cset : f1bd314e64ac

[STR] D2D/DW/D3D all ON. new profile.
go into Panorama mode.
change Aero theme to Basic theme.
back to normal mode.
back to Aero theme.
it did happen on a new profile, I was able to reproduce, though i only tested build: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100911 Firefox/4.0b6pre ID:20100911185742
Why does this have [Jaegermonkey] in the title? I can reproduce this bug when acceleration is enabled, but it happens regardless of javascript.options.methodjit.chrome's setting.
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)

re-check and nothing to do with JM.
so change  bug title.
Summary: [Jaegermonkey] caption buttons are not rendered correctly, and Aero missing. → caption buttons are not rendered correctly, and Aero missing.
Only way we've found to fix the caption buttons and missing Glass effects without restarting the browser is to hit the maximize or restore caption button. That seems to trigger whatever repaint is needed.

CCing Bas, as this is an acceleration issue.

Updated

7 years ago
Component: Theme → General
Product: Firefox → Core
QA Contact: theme → general

Updated

7 years ago
Depends on: 585964

Comment 5

7 years ago
Could it be that triggers the 'black box' effect on the caption buttons in Areo on custom themes?
See http://imagepaste.nullnetwork.net/viewimage.php?id=1292
button-box here doesn't have the -moz-appearance:-moz-window-button-box style, so it should be not displaying except for its contents (the buttons themselves, which are styled in the usual way).

Comment 6

7 years ago
(In reply to comment #5)
> Could it be that triggers the 'black box' effect on the caption buttons in Areo
> on custom themes?
> See http://imagepaste.nullnetwork.net/viewimage.php?id=1292
> button-box here doesn't have the -moz-appearance:-moz-window-button-box style,
> so it should be not displaying except for its contents (the buttons themselves,
> which are styled in the usual way).

No, this is something different. What type of fx theme is this?
(Reporter)

Comment 7

7 years ago
(In reply to comment #0)
> Created attachment 474460 [details]
> screenshot
>
> [STR] D2D/DW/D3D all ON. new profile.
> go into Panorama mode.
> change Aero theme to Basic theme.
> back to normal mode.
> back to Aero theme.

seems to be fine now.

should mark as WORKSFORME ?

Comment 8

7 years ago
Thanks for the follow up!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.