Closed Bug 595595 Opened 10 years ago Closed 10 years ago

Language and locale: Catalan, content shown: Spanish

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: pau.iranzo, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; ca-valencia; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; ca-valencia; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8

I have installed the Catalan version and the locales are set to Catalan (1st) and English (2nd).

Even though all this, when I type Google on the omnibar, Firefox goes directly to the Spanish version of Google (www.google.es) ignoring the Catalan version (www.google.cat). 

If I type "Wikipedia", Firefox goes directly to the Spanish Wikipedia, and not to the Catalan version. 

If I go to www.google.cat and search for "Wikipedia", the first result is the Spanish wikipedia. The Catalan version is the second one.

If I do the same on Google Chrome, all this results show the Catalan version first. 

Why Firefox doesn't respect my first locale and keep showing results not related to my locale?

I live in Catalonia (Spain), but there is no reason to show results in a language that I haven't chosen on my configuration. I guess this is related to my location (Spain), but it shouldn't be this way.

Reproducible: Always

Steps to Reproduce:
1. From Catalonia. Set locale and language to Catalan.
2. Open Firefox
3. Type "wikipedia" or "google" on the omnibar
Actual Results:  
Firefox goes to the Spanish versions even though there exist Catalan versions.

Expected Results:  
Firefox should show the Catalan results first, as long as the locales are set to Catalan.

Tried on Google Chrome and it does work: Catalan results are first.
It's Google that determines which content it's going to show, Not Firefox. There could indeed be a difference between Firefox and Chrome, but it's exactly easy to see how they do it. Many websites completely ignore any hints that the browser is giving, Google is actually one of the better ones.

You can try comparing the results you see when loading <http://browserspy.dk/language.php> in Firefox and Chrome.

As an aside, I think you're using the Valencian language pack, as there's no official supported ca or ca-valencia version of the browser. I think that Chrome is Catalan actually, which might make a difference (the language code is different, ca and ca-valencia). I see that the English version of Firefox doesn't know anything about Valencian, so I don't know what they did in the language pack. Maybe they only changed the user-agent string, and left the Accept-Language header alone ? (see below)

- 'Language' test : there's a locale in your user-agent string (which is going away in Firefox 4.0 by the way), but that's probably not used. Maybe it's because you're using ca-valencia instead of ca, but I doubt it.

- 'Accepted Languages' : there's a Accept-Language header in the http-request, which is the one you can influence in the preferences. Some websites don't like that they can see multiple results (you have 2), and will only take the first one, or ignore the complete header when they can't figure it out. Note that if you have a complicated language with a subtab, you will often have problems too, if they get parsed incorrectly (my nl-be is often ignored, even when an nl works).

- there's also the possibility to use the ipaddress to guess the region where you live, even though that's often wrong for small regions, or even impossible. I don't think that anyone can guess that you're in Catalonia based on your ipaddress. Some websites seem to think that they can also determine your preferred language out of a region, but that obviously doesn't work for everybody (like for Catalonia if they think you have an .es ipaddress), and most definitely not for multi-lingual regions like Belgium, Canada, Switzerland, etc...

- the exact behavior can also be different per domain : google.es might have different rules then google.cat (the default language for sure). Also note that google.com isn't the English version, but will be mapped to the local domain, so I wouldn't be surprised that if behaves like google.es. Also note that this will function differently when you travel in another country (in Sweden, google.com will give you content in Swedish by default).

- and the very most important sign : it uses a cookie ! You can set your preferred language at the bottom of every welcome page. If you click that once, you will force Google to operate in that language wherever you are. But if you clear your cookies, you might have to remember to reset your choice of Catalan again, as you might end up in google.es again.

In the past, I've read reports that Google was in general NOT respecting the Accept-Language header, and choose the ipaddress method. But I know for sure that it currently uses (at least in Belgium) the header to determine the default language. Other people could not reproduce this, so it might be a rule that only works in Belgium. I don't know if it works in Catalonia too, but if it does, it might have a problem with Valencian too, as mentioned above.

And there's another problem : if you do your Google searches in the toolbar, it will be the language of that search-plugin, not the cookies or the ipaddress or the header. You should be able to see the language in the URL. Your language pack should normally have installed a different locale, and the default search-plugin is supposed to use that. But in the past (when the locale was hardcoded in the plugin), some language packs installed their own search-plugin. Can you check if it's correct ? If necessary, it's possible to change the search plugin manually.

I don't think this is a problem for Firefox, as it's totally determined by the website itself. Your choice of Valencian might complicate the matters a bit, but that also depends on the website (Google should ignore the subtag, and return Catalan). It's also possible that the language pack made a mistake somewhere.

But your Google problems should immediately be solved by forcing the Google cookie to Catalan. As I don't see a switch on google.cat except for english (hmmm ... might be political), I suggest to go to google.es. Or go to the Google preferences.
Hi Jo,

It was my Ubuntu that was the ca-valencia locale defined, but not Firefox. In any case, I've changed the Ubuntu locale to «Catalan» and started a new profile in Firefox with no cookies. 

Still the same: Firefox show Spanish results first even in www.google.cat. Chrome shows the Catalan one.

I've tried typing on the address bar with Midori and the result was the same as Firefox: Spanish results first. Opera showed Catalan results first. 

In all of them, after going to www.google.cat and searching for "wikipedia", the Spanish result was first (also in Chrome).

This is really annoying. I can't understand why Spanish results appear on the search results when there are results in Catalan. It could be the same for an English user if a German or French result appeared on its searches when there were results in English.

:(
Hi Pau,

tell me the specific searches and first results for the different terms. May you check also what I comment below?

For instance, myself (in Barcelona, Southern Catalonia), I've noticed that in my old profile (Catalan Firefox default Accept-header language: ca, en-US, en) and using default Google searchplugin (http://hg.mozilla.org/releases/mozilla-1.9.2/file/479e854879e5/browser/locales/en-US/searchplugins/google.xml), so generating the following URL: http://www.google.es/search?q=Wikipedia&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:ca:official&client=firefox-a) I get ca.wikipedia.org first. 
Paradoxically, using google.cat searchplugin, such as the ones me or Jordi Rossell created (http://www.cau.cat/blog/googlecat_com_a_motor_de_cerca_per_defecte), I get es.wikipedia.org first.
Rellevant URLs:
http://www.google.cat/search?q=Wikipedia&ie=utf-8&oe=utf-8&aq=t
or even adding Firefox-specific parameters:
http://www.google.cat/search?q=Wikipedia&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:ca:official&client=firefox-a

The quick conclusion is that google.cat domain is actually favouring Spanish content despite what its domain might suggest. I get the same result for Google Chrome (I think Accept-header languages: ca-ES, ca) using google.cat vs default google.es (in my territory)

(In reply to comment #2)
> Hi Jo,
> 
> It was my Ubuntu that was the ca-valencia locale defined, but not Firefox. In
> any case, I've changed the Ubuntu locale to «Catalan» and started a new profile
> in Firefox with no cookies. 
> 
> Still the same: Firefox show Spanish results first even in www.google.cat.
> Chrome shows the Catalan one.
> 
> I've tried typing on the address bar with Midori and the result was the same as
> Firefox: Spanish results first. Opera showed Catalan results first. 
> 
> In all of them, after going to www.google.cat and searching for "wikipedia",
> the Spanish result was first (also in Chrome).
> 
> This is really annoying. I can't understand why Spanish results appear on the
> search results when there are results in Catalan. It could be the same for an
> English user if a German or French result appeared on its searches when there
> were results in English.
> 
> :(
(In reply to comment #2)
> Hi Jo,
> 
> It was my Ubuntu that was the ca-valencia locale defined, but not Firefox. In
> any case, I've changed the Ubuntu locale to «Catalan» and started a new profile
> in Firefox with no cookies. 
> 
> Still the same: Firefox show Spanish results first even in www.google.cat.
> Chrome shows the Catalan one.
> 

Have you tried to set the Google cookie ? That should at least force Catalan on google.es. I don't really understand what google.cat is doing (comment 2).
Hi,

I can confirm that this is a google.cat issue. On the other hand, I can understand that as long as google.cat is not related to an actual State, the firefox omnibar prefers to go to the googles.es domain (showing text in Catalan).
(In reply to comment #5)
> Hi,
> 
> I can confirm that this is a google.cat issue. On the other hand, I can
> understand that as long as google.cat is not related to an actual State, the
> firefox omnibar prefers to go to the googles.es domain (showing text in
> Catalan).

Hi Pau,

this is a Google-side issue since now there is only one Google searchplugin for all locale versions of Firefox.
I complained about this in the past: https://bugzilla.mozilla.org/show_bug.cgi?id=345479 As we well know, most Catalan-speaking users who use Firefox do not appreciate being redirected to an es domain.
In any case, I close this bug. We should find a way to send the complaint to Google now. If we wanted to change the resulting domain, if not done from Google themselves (most preferrable), discussion should go through other ways/bugs in Mozilla.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
I cc a Google address from another bug so they are informed by that way at least.
You need to log in before you can comment on or make changes to this bug.