If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Work Offline" in the Firefox button menu isn't checked if you're offline

VERIFIED FIXED in Firefox 4.0b7

Status

()

Firefox
Menus
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

Trunk
Firefox 4.0b7
Points:
---
Bug Flags:
in-litmus ?

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
"Work Offline" in the Firefox button menu isn't checked if you're offline.
(Assignee)

Updated

7 years ago
blocking2.0: --- → ?
"Work Offline" is going away anyway.
(Assignee)

Comment 2

7 years ago
It's not going away in Firefox 4, which means the menu item needs to work correctly there.
http://limi.net/articles/papercuts/
Quote: "Work offline must die"
(Assignee)

Comment 4

7 years ago
Again: It's not going away in Firefox 4.
Tell that to Alexander. I'm only quoting text.
Not sure where you get this information from but there hasn't been talked about any target milestone. You should better read before quoting text. An ongoing discussion can be found on bug 565564.
(In reply to comment #6)
> Not sure where you get this information from

Hint: Notice that link.

On the other hand, work offline is the most annoying feature in Firefox to date. Because after re-connecting to the Internet I have to *manually* turn it off every time. It took me some *months* before I realize it's because of this and I don't have to restart the entire browser (note I don't have an idea what work offline is, nor where to find it). That's just plain stupid.
(In reply to comment #7)
> (note I don't have an idea what work offline is, nor where to find it)

Correction: (note I didn't have an idea what work offline is, nor where to find it)
(In reply to comment #5)
> Tell that to Alexander. I'm only quoting text.

But you're doing so in a combative and unhelpful way - if you think Dao's wrong when says it's staying around in FF4, something more constructive would be to illustrate where that decision was made. Since it hasn't been made, though, because Dao is correct, quoting Limi back at him is unhelpful.

Of course, either of you could have cc'd Limi, too. :)
blocking2.0: ? → final+
Yes, please keep things civil, Peter — you're dangerously close to being banned here if you can't step down the attacks and general unpleasant attitude in Bugzilla lately.

Anyway, to talk about the issue:

- I still haven't been able to identify any *real* reason why we can't just remove the "Work Offline" functionality altogether. The online/offline detection should be solid on all the major platforms we ship on at this point.

- That being said, if we're not removing it (not really my call, since I can't implement the change myself), the menu option should work like it used to, like Dao points out.

I'm hoping that removing the Work Offline functionality altogether is easy, but I really have no idea of the scope of such a change.
(In reply to comment #9)
> (In reply to comment #5)
> > Tell that to Alexander. I'm only quoting text.
> 
> But you're doing so in a combative and unhelpful way - if you think Dao's wrong
> when says it's staying around in FF4, something more constructive would be to
> illustrate where that decision was made. Since it hasn't been made, though,
> because Dao is correct, quoting Limi back at him is unhelpful.
> 
> Of course, either of you could have cc'd Limi, too. :)

I dunno, that is why I linked to it. I can swear I saw this somewhere else too, but I don't remember where. Anyway, I was confused as I saw both informations from the official sources.
But my experience with the feature itself stands.

(In reply to comment #10)
> Yes, please keep things civil, Peter — you're dangerously close to being banned
> here if you can't step down the attacks and general unpleasant attitude in
> Bugzilla lately.

I did appologize personally for me behaviour and I can't see any attacking against Dao. I respect him, but as I said, I was confused. And I'm still am. Will be Working offline removed or not?
(In reply to comment #11)
> I did appologize personally for me behaviour and I can't see any attacking
> against Dao. I respect him, but as I said, I was confused. And I'm still am.
> Will be Working offline removed or not?

That's not what this bug is about, try bug 539535 instead. :)

Right now, nobody owns that one, so it's likely that it'll stay around for 4.0 unless someone cares enough about it to fix it.
There is bug 565564 for that, which is confirmed and this: https://wiki.mozilla.org/Firefox/Projects/UX_Priorities#Firefox_menu
> Making sure Work Offline is removed (ie. never stuck in offline mode)
See? *This* is what I was talking about. (This one particular is in direct oposite to what this bug wants to do and it would clash with bug 565564.) Currently there isn't final decission for it, as both *official* sources is telling different things. Either it stays, or not.
Please, make that decission. Thank you.
(Assignee)

Updated

7 years ago
Assignee: nobody → dao
(Assignee)

Comment 14

7 years ago
Created attachment 476858 [details] [diff] [review]
patch
Attachment #476858 - Flags: review?(dolske)
Attachment #476858 - Flags: review?(dolske)
Attachment #476858 - Flags: review+
Attachment #476858 - Flags: approval2.0+
Comment on attachment 476858 [details] [diff] [review]
patch

(Oops, the a+ wasn't needed on this patch since it's already blocking final+; I'll just leave it to prevent any confusion over what might be meant by removing it. :)
Attachment #476858 - Flags: approval2.0+
(Assignee)

Comment 16

7 years ago
http://hg.mozilla.org/mozilla-central/rev/8528ce3f97ce
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b7
Verified fixed with Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101023 Firefox/4.0b8pre
Status: RESOLVED → VERIFIED
Flags: in-litmus?
Flags: in-litmus? → in-litmus?(abillings)
Henrik, you're suggesting this for a Firefox 4 testcase?
(In reply to comment #18)
> Henrik, you're suggesting this for a Firefox 4 testcase?

Sure. Given our Beta page on the wiki, you are responsible for that area. That's why I have assigned it to you.
Flags: in-litmus?(abillings) → in-litmus?
You need to log in before you can comment on or make changes to this bug.