Closed Bug 59563 Opened 20 years ago Closed 20 years ago

Table Cell colors don't show up if there is no text in it

Categories

(Core :: Layout: Tables, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 8113

People

(Reporter: sp_regan, Assigned: karnaze)

References

()

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20001108
BuildID:    Milestone 18

In every table that i have noticed, if it is supposed to have a colored
background but there is no text in the cell, it appears blank and has no
background color.

Reproducible: Always
Steps to Reproduce:
Just look at a table without any text in a cell

Actual Results:  The Cell Background Color Didn't Show Up	

Expected Results:  Shown the background color

Simple example of problem:

<table border="1" width="100%">
  <tr>
    <td width="50%" bgcolor="#008000">text</td>
    <td width="50%" bgcolor="#008000"></td>
  </tr>
  <tr>
    <td width="50%" bgcolor="#008000"></td>
    <td width="50%" bgcolor="#008000">text</td>
  </tr>
  <tr>
    <td width="50%" bgcolor="#008000">text</td>
    <td width="50%" bgcolor="#008000"></td>
  </tr>
  <tr>
    <td width="50%" bgcolor="#008000"></td>
    <td width="50%" bgcolor="#008000">text</td>
  </tr>
  <tr>
    <td width="50%" bgcolor="#008000">r</td>
    <td width="50%" bgcolor="#008000"></td>
  </tr>
</table>
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Confirming with latest Linux nightly build. Changing OS to All.
This has been a default behaviour in Mozilla and NS4. I read the spec and could not find whether this is the correct behaviour or not.

Anyway, this can be fixed by using &nbsp; inside the empty cell.

Konqueror (KDE2) shows the background, and I believe IE does the same.
OK, browsing other bugs I found what the spec says:
http://www.w3.org/TR/REC-CSS2/tables.html#table-layers

According to it, this bug is invalid:
"The topmost layer contains the cells themselves. As the figure shows, although all rows contain the same number of cells, not every cell may have specified content. These "empty" cells are transparent, letting lower layers shine through."

Maybe this is a compatibility issue, but if we're going to follow the spec, then thing remains the same.
Whether Mozilla is doing the right thing or no, this bug has been reported
previously. Bug 8113 seems to be the canonical version.
Yes, this is a dup of 8113 - marking it so.

*** This bug has been marked as a duplicate of 8113 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.