If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

message list displays incorrect subject

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
major
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: spence, Assigned: scottputterman)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20001102
Netscape6/6.0
BuildID:

A message in the message list pane is displayed with an incorrect subject.

Reproducible: Sometimes
Steps to Reproduce:
I have no idea how to reproduce this, but once it's happened, it persistent.
How did you get away without giving a Build ID? ;-) Was it the browser you used 
to submit the report?

Is the incorrect subject rubbish, or the subject of another message in your 
inbox?

Gerv
(Reporter)

Comment 2

17 years ago
I was running Netscape 6 ... there was no build ID in the described location ...

> Is the incorrect subject rubbish, or the subject of another message in your
> inbox?
>
> Gerv

The incorrect subject is an "Re:" of another message in my inbox. Literally,
when I compare my inbox in Netscape 6 to that of another mail program,
everything is identical _except_ the subject of this particular message.

In the message body pane everything is correct. It is the header displayed for
this message in the thread pane.

The problem persists.
esther@netscape.com - is there any debugging information you need here? I'm 
unlikely to be able to reproduce this...

Gerv

Comment 4

17 years ago
Marking INVALID due to lack of response and information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
We don't do Netscape 6 bugs. INVALID, VERIFIED.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

17 years ago
So, from what I've read here, nothing has been done about this bug, and nothing 
will be.  

Now the bug report is marked INVALID.  Whatever.  The bug happened, persisted, 
and reduced my confidence in using Netscape 6 for mail.

If this is the kind of response I can expect to my efforts to help Netscape 
kill bugs, I won't bother again.  I only filed the original bug because a 
Netscape employee (and friend) told me to file bugs rather than complain.

from http://bugzilla.mozilla.org: right hand column


What's all this, then?

This is mozilla.org's bug-tracking system, our database for recording bugs in
Mozilla and other mozilla.org projects. For more information about Bugzilla, see
our bug page.

This is not the place to report bugs about commercial Netscape products. For
that, try Netscape's own bug reporting form instead. Netscape bugs reported here
will be ignored. (Netscape browsers usually have a blue and black `N' logo in
the top right of the window.)

Now, if you see this with a nightly *Mozilla* build from ftp://ftp.mozilla.org
let me know and I'll re-open.
(Reporter)

Comment 8

17 years ago
Good grief.

It should be as easy as possible for a naive user to report a bug.  Whether a 
bug is reported against moz or ns, the user should not always be expected to 
know the difference.

But the problem is *this* -   Our mozilla 0.6 release was actually the same
codebase as our Netscape 6 shipping code, with a few bug fixes here and there.
I can tell you we've fixed no less than 20 bugs in time since Netscape 6.0 (and
Mozilla 0.6) have been released.  Besides, Mozilla is geared towards developers,
not end-users, meaning hopefully someone uses Mozilla on as close to a daily
basis as possible, downloading the latest builds everynight.  If end-users file
bugs about stagnant products (when they could easily get their hands on a recent
build), of course we're going to mark it INVALID.

So, if you download a nightly and report it using the latest build, that's
great.  Using a 2 month old product is *not*.

Thanks.
QA Contact: esther → stephend
(Reporter)

Comment 10

17 years ago
> If end-users file bugs about stagnant products (when they could easily get
> their hands on a recent build), of course we're going to mark it INVALID.


The bug was filed 11/8, right around the time of the 0.6 (6.0) release.

Bug reports shouldn't be dropped on the floor. Forward them to the more
appropriate recipient. There ought to be a bit bucket for moz folx to quickly
throw things to ns folx.

> So, if you download a nightly and report it using the latest build, that's
> great.  Using a 2 month old product is *not*.

The product wasn't stale when the bug was filed.

> Thanks.

No prob.

Comment 11

17 years ago
Stephen: I'm sure you can find a nicer and more polite way to nudge nudge hint
hint people towards the Netscape bug report pages. This mistake is easily made,
no need to become impolite (yes, life can be hard when you see a couple of these
a day, so ask someone else to be polite and smile for you ;-) ).

spence: could you download a more recent Mozilla build and see if you can
reproduce this bug? If you can, please reopen this bug.

Comment 12

17 years ago
mozilla0.6 was stale months before it was released.

It was not for use by normal users. Mozilla0.6 is for people who need to do 
development work for netscape6 and maintain extreme compatibility.

An example of this is MathML.

You should have been using an M18 build.

You never attached your inbox to the bug. You never attached pictures to the 
bug.

Do not reopen this bug.  If you want to try again, please get a mozilla0.7 or 
nightly build (prefered) and attach all of the requested pictures and files 
that I mentioned here.

Please use the bugzilla helper correctly and fill in all fields.
Let me clear some things up so I'm not misunderstood:

When I marked it VERIFIED, INVALID, I used all caps.  This is how we in QA can
easily tell it bugs have been marked FIXED/VERIFIED/RESOLVED, etc.  So if it
seemed like I shouted, I'm sorry.

http://home.netscape.com/browsers/6/feedback/index.html is the link for general
Netscape 6 feedback, and http://help.netscape.com/netscape6/emailsupport.html
is our actual Decision One branded support for the Netscape 6 client product.

As I stated a couple of times before, if you see this happening on a recent
Mozilla build, I will be more than happy to investigate (I'm not currently
having this problem on my latest in-house Netscape 6 build).

This is an easy mistake and I should've responded with the link to the Netscape
support pages when I marked it INVALID.  I apologize for that.

Sorry,

Stephen Donner

Comment 14

17 years ago
Possible database corruption?  Adding bienvenu; what's the standard,
reset-imap-databases procedure?

Stephend wrote:
> We don't do Netscape 6 bugs. INVALID, VERIFIED.

Chances are pretty good that this bug applies
to the mozilla product as well.  Mozilla should
be grateful for testing by external people, this
includes Netscape 6.x users.  The Netscape-branded
browsers cover a lot of Mozilla ground, we can't
afford to blow them off like this.  At the very least,
this bug should have been forwarded to Netscape
instead of lost in the VERIFIED INVALID pool.


Comment 15

17 years ago
you can delete your Inbox.msf file on disk to blow away the database. I've never
seen this happen to me, however, and I've never heard any reports of it, so I
don't think it's a general problem. Is it just the subject that's wrong, or are
the sender, date, size, etc, also wrong? 
(Reporter)

Comment 16

17 years ago
bienvenu: I can't answer your questions at the moment as I'm now out of town 
for the next several days and don't have access to the machine in question. 
I'll check things out once I'm back.

Thanx to all for looking into this.
I'll reopen.
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Spence, can you still see this with a recent build?
Spence, have you had a chance to look at this in the past month?  
No response in over two months, and no steps to reproduce.  Per 
http://www.mozilla.org/quality/browser/prescreening.html I'm marking this bug 
worksforme until I get a clearer case or I see it myself.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
Still no information from either myself or Spence on this, so verifying to get
off radar.  As mentioned ealier, we can and will file new bugs if we can
reproduce this.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 22

17 years ago
stephend: I haven't been able to reproduce the problem since the original 
occurance.

Comment 23

16 years ago
Created attachment 60162 [details]
INBOX with incorrect headers displayed

Subject in question is 2001/2002 Upcoming Activities

Comment 24

16 years ago
I am running 0.9.6 and see the same problem.

I had 2 identical messages in my inbox.  I viewed and deleted the second one. 
The header display still showed the 2 identical headers, but the second message
was a different message, correctly displayed in the display window.  Don't know
whether the identical messages is related.  Since I started writing this report,
a new message that has just come in also appears on the list with the same
incorrect name, sender, and date, then several messages came in and one of them
had the wrong header info.

Will send copy of my inbox as it stands.

Comment 25

16 years ago
Just as a followup, following yesterday's restart I left Mozilla up overnight. 
Both the mail agent and browser crashed this morning attempting to open a link
from a mail message.  The incorrect header display is now correct.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.