"image cannot be displayed because it contains errors" is displayed when stopping load a partially loaded image

RESOLVED DUPLICATE of bug 602108

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 602108
8 years ago
8 years ago

People

(Reporter: c221752, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100912 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100912 Firefox/4.0b6pre

When I try to load a new webpage while in there is an image that has not finished loading, the image disappears and a message "the image <...> cannot be displayed because it contains errors" is shown instead until the new webpage loaded.

Reproducible: Always

Steps to Reproduce:
1. Load an heavy image, such as http://www.freeanimalswallpapers.com/images/wallpapers/Koala-Smile-111971.jpeg, and before it finishes loading go to step 2.
2. Now load another webpage in the same tab (preferably something not in cache, that take a moment to retrieve).

Actual Results:  
While loading the new page, the image that hasn't finished loading disappears and the text "the image <...> cannot be displayed because it contains errors" is shown instead.

Expected Results:  
Show the partially loaded image until the new page is loaded.
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

8 years ago
Actually happens when stopping page load as well (pressing Escape, etc.).
Summary: "image cannot be displayed because it contains errors" is displayed when moving from partially loaded image to another page → "image cannot be displayed because it contains errors" is displayed when stopping load a partially loaded image

Comment 2

8 years ago
its better seen in any bmp image. jpegs load too fast for me.
http://www.google.com/images?hl=en&q=bmp

i can confirm this with Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b7pre) Gecko/20101004 Firefox/4.0b7pre
I always thought this was the intentional behavior, as it's been going on since at least the Firefox 3.6 days for me. At any rate, I can confirm this as well.

Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b7pre) Gecko/20101004 Firefox/4.0b7pre ID:20101004041645

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: General → ImageLib
Product: Firefox → Core
QA Contact: general → imagelib
Resolution: --- → DUPLICATE
Duplicate of bug: 58880
Duplicate of bug: 565773
Duplicate of bug: 602108
You need to log in before you can comment on or make changes to this bug.