Crash opening CKEditor on devmo ([@ js::TraceRecorder::prop ])

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: sheppy, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Reporter)

Description

7 years ago
Opening up the editor on MDC is crashing on the current nightly. Crash log shows the crash looks like it's happening in JaegerMonkey related code -- certainly in the JavaScript engine.

Crash log related to this is here:

http://crash-stats.mozilla.com/report/index/80e36df7-1c18-4a15-86c1-ec5a22100912

Obviously for me this one is of particular interest. :)
I see this too.

My signatures are identical to the one of Eric:  [@ js::TraceRecorder::prop ] 
Disabling MethodJIT work around the problem.

Note: that the problem seems also to happen on Windows, with a slightly different signature: 
http://crash-stats.mozilla.com/report/list?range_value=2&range_unit=weeks&date=2010-09-12%2019%3A00%3A00&signature=js%3A%3ATraceRecorder%3A%3Aprop%28JSObject*%2C%20nanojit%3A%3ALIns*%2C%20unsigned%20long*%2C%20nanojit%3A%3ALIns**%2C%20js%3A%3AValue*%29&version=Firefox%3A4.0b6pre

Comments left by user indicates "clicking edit page", which is exactly what we do on the MDC.
(Reporter)

Updated

7 years ago
Summary: Crash opening CKEditor on devmo → Crash opening CKEditor on devmo ([@ js::TraceRecorder::prop ])

Updated

7 years ago
OS: Mac OS X → All
Hardware: x86 → All
This also does not occur if javascript.options.tracejit.content is false: the stack indicates it is a bug in tracejit/methodjit integration.
I can see this on Mac on the latest nightly when I enable the rich text editor in wiki.m.o
blocking2.0: --- → ?
I can't reproduce this with tm-tip or the latest nightly on wiki.m.o. I can't confirm the original STR, devmo won't let me create an account (I get some error about an expired MindTouch license).

Can anyone confirm if this is still a bug?
(Reporter)

Comment 5

7 years ago
This does appear to be fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME

Updated

7 years ago
blocking2.0: ? → betaN+
You need to log in before you can comment on or make changes to this bug.