Hang during keyboard navigation

VERIFIED FIXED in mozilla0.9

Status

()

P1
normal
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: dprice, Assigned: anthonyd)

Tracking

({hang})

Trunk
mozilla0.9
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: FIX IN HAND, URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Browser hangs while trying to arrow down into a <TABLE> that's in a <SPAN>
(Reporter)

Comment 1

18 years ago
Created attachment 18982 [details]
Attaching test case
(Reporter)

Updated

18 years ago
(Reporter)

Comment 2

18 years ago
Created attachment 18984 [details] [diff] [review]
attached a fix, r=mjudge
(Reporter)

Comment 3

18 years ago
now all I need to do is tell you how to reproduce it ;)

Simply click to place the cursor in the top left corner, and hold down the down
arrow.  You'll hang when the it tries to move into the table.
(Assignee)

Comment 4

18 years ago
setting milestone
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9
(Assignee)

Updated

18 years ago
Whiteboard: FIX IN HAND

Comment 5

18 years ago
simon, can you sr?
(Assignee)

Comment 6

18 years ago
*** Bug 61111 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

18 years ago
change is in my tree, looks good.  r=mjudge, kin
need a= from buster.

can you check it out for me buster and give me your a=?

thanks,
anthonyd
(Assignee)

Comment 8

18 years ago
waiting on approval to check in.

anthonyd

Comment 9

18 years ago
I'm on vacation, but fortunately checking my mail :)
waterson, can you sr for me please?

Comment 10

18 years ago
I'd prefer if you tested that ``blockFrame != aPos->mResultFrame'' in the
enclosing if statement (where you test aPos->mResultFrame). There doesn't appear
to be any need to execute the ``else'' clause where you force result to be NS_OK...
(Assignee)

Comment 11

18 years ago
Created attachment 20238 [details] [diff] [review]
new patch with watersons recommended change, please re-review
(Assignee)

Comment 12

18 years ago
setting to p1.
waiting on re-review from waterson.

anthonyd.
Priority: P3 → P1

Comment 13

18 years ago
*** Bug 61230 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

18 years ago
waterson, buster,

can i get a kwik review with watersons change?

anthonyd

Comment 15

18 years ago
sr=buster

Comment 16

18 years ago
So can we get this in?

Updated

18 years ago
Keywords: hang
(Assignee)

Comment 17

18 years ago
fix checked in.

anthonyd
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 18

16 years ago
catching up on verifications
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.