File download hangs browser.

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: osantanen, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9 (.NET CLR 3.5.30729)

If I want to download a file from gmail (f.g. name.doc), browser hangs (wait cursor, do not respond any more). This does not happen with Firefox on Xubuntu platform. Browser hangs also when I try to download name.war file to my network Glassfish application server in Ubuntu 8.04 server edition using administration console with Firefox browser (this does not happen with IE 8.0). The same hanging behaviour has happened in several webpages before I noticed that this is a Firefox issue, not broken webpage. My computer is HP Compaq nx6310 with Window XP professional.

Reproducible: Always

Steps to Reproduce:
1.try to download name.doc-file from myname@gmail.com email-service
2.
3.
Actual Results:  
you see wait cursor, and browser do not respond any more, you have to restart Firefox to continue.
open about:config (enter as URL), confirm the warning, enter scanwhen in the top filter bar and change browser.download.manager.scanWhenDone from true to false.
Does it work now ?
(Reporter)

Comment 2

8 years ago
Sorry, the change of browser.download.manager.scanWhenDone from true to false did not help. I restarted browser with no further luck.
This setting disables the calling of the registered antivirus software for scanning the downloaded file.

Do you always get a freeze if you download something ?

The name.war case could be something different. I bet your internal server is broken and sends the file as text/plain. The browser will try to render the file in that case and that could take a very long time. IE is wrong in this case if offers to download it.

Downloading works for me using FF3.6.9 on win32 and a example.doc file from gmail.

Can you try a new profile ?
http://support.mozilla.com/en-US/kb/Managing+profiles
(Reporter)

Comment 4

8 years ago
Yes, browser freezes every time I try to download a file in gmail, and  the same happens also every time I try to deploy webapplication.war file to Glassfish application server in its administration portal(not command line) using Firefox. Basicly it could be caused by the same problem, because only Firefox (not IE) freezes during downloads of those files.

I am sure it does not depend on the profile. I have 4 different profiles because I try to develop an extension. First, I supposed it could be because of my own extension, but if I uninstall my extension or make a new profile, the problem stays there.
>Yes, browser freezes every time I try to download a file in gmail,
No !
I assumed that it always freezes at gmail.
I want to know if it freezes every time you download a file from somewhere (and not gmail or your .war files). I mean for example a file from ftp.mozilla.org.

Is this problem new with 3.6.9 ?
(Reporter)

Comment 6

8 years ago
My browser downloads files otherwise normally but freezes only at gmail and that .war file case. At my work Firefox downloads files at gmail well although there are the same programs {Windows XP Professional and Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9}. 

The problem is new with 3.6.9, but so is my gmail account and my use of glassfish application server. 

I could try to debug my browser's javascript with Firebug/Javascriptdebugger if you tell me the name of file where to put the first break.

Updated

8 years ago
Version: unspecified → 3.6 Branch
WFM with latest Nightly on Win 8 64-bit: I can download files from gmail without Firefox hanging.

Please reopen the bug if you still see this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.