Popup XUL windows opens with opener's size mode once, then resizes position and size

RESOLVED DUPLICATE of bug 597576

Status

()

Core
Widget: Win32
RESOLVED DUPLICATE of bug 597576
7 years ago
7 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 474667 [details]
popup sample

Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100912 Firefox/4.0b6pre ID:20100912041924

when a pop-up window opens it initially tries to size to the same size as the main window, it then resizes down to the correct size before drawing the content.

This is quite disconcerting as the windows flashes about across the screen.

It is even more noticeable if the main window is maximized.

This is similar to Bug 594881, but this is popup window by javascript.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open Gmail and login
3. Shift Click "Compose mail"

Actual Results:
 The windows flashes.

Expected Results:
 The windows does not flash.

Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/522df66198cf
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100624 Minefield/3.7a6pre ID:20100624185700
Fails:
http://hg.mozilla.org/mozilla-central/rev/51bd519736c4
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100624 Minefield/3.7a6pre ID:20100624221810
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=522df66198cf&tochange=51bd519736c4
Candidate:
Bug 513162 - [Windows] Drawing in the Title Bar for the New Firefox Theme

Updated

7 years ago
No longer blocks: 513162
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575184

Comment 2

7 years ago
oops.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

7 years ago
Hmm, WFM, vista - aero glass and classic mode. Any tricks to reproduce this alice?
(Reporter)

Comment 4

7 years ago
It happens Windows 7 Classic and Aero Basic may not happens Aero.
It happens Windows XP.
It does not happen in Linux, 
I do not try on Vista.

1.Open browser
2.Make it normal mode and resize small size than maximized window size
3.Maximized
4.Open sample
5.Click a link to popup
(Reporter)

Comment 5

7 years ago
In Windows 7, if you set "Animate windows when minimizing or maximizing", the problem become more terrible.

1. Open Control panel
2. In the performance section
3. Check "Animate windows when minimizing or maximizing", maybe default on.
This happens on every javascript popup for me on XP, standard Luna interface. It occurs regardless if show show the firefox button or the menu bar, and regardless if tabs are on top or not.

Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100913 Firefox/4.0b6pre
(Reporter)

Comment 7

7 years ago
ogg video
http://space.geocities.jp/alice0775/REQUEST/bug595811_XP.ogg
Status: REOPENED → NEW
Is this a regression from 3.6?  If so, please add the regression keyword....
blocking2.0: --- → ?
Blocks: 597576
Keywords: regression
blocking2.0: ? → betaN+
Assignee: nobody → jmathies

Updated

7 years ago
Assignee: jmathies → nobody
No longer blocks: 597576
Status: NEW → RESOLVED
blocking2.0: betaN+ → ---
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 597576
You need to log in before you can comment on or make changes to this bug.