Closing firefox 4.0b5 with multiple tabs open via the taskbar causes it to become inaccessible.

RESOLVED DUPLICATE of bug 586299

Status

()

RESOLVED DUPLICATE of bug 586299
8 years ago
8 years ago

People

(Reporter: nicholas.sims, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET CLR 1.1.4322; InfoPath.2; .NET4.0C; .NET4.0E; OfficeLiveConnector.1.5; OfficeLivePatch.1.3)
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

When Firefox 4.0b5 is minimized and has multiple tabs open, if I right-click the Firefox icon in the taskbar and choose 'close' it doesn't close and  Firefox becomes inaccessible. 

Reproducible: Always

Steps to Reproduce:
1. Open up more than one tab that isn't blank.
2. Minimize Firefox.
3. Right-click on the icon in the taskbar, and choose close.
Actual Results:  
Firefox doesn't close, and clicking on the preview or alt+tabbing into firefox does nothing.

Expected Results:  
It should ask if I want to save the tabs, exit without saving or to cancel.

This has happened to me since 4.0b4, and continues to happen after installing 4.0b5.
(Reporter)

Comment 1

8 years ago
Can still be closed by task manager, though if it is not killed via processes but by applications, it says that it is waiting for a response from the user.

After a bit more playing around, If I close each individual tab via the taskabr preview after it has become unresponsive, I can bring up the final tab on screen. However, if I click on it all I get is a ding noise; meaning that it supposedly has the 'save, exit, cancel' window open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 586299
You need to log in before you can comment on or make changes to this bug.