Loss of aero glass after disconnect/connect of external monitor

RESOLVED FIXED

Status

()

Core
Widget: Win32
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Pedro, Assigned: jimm)

Tracking

unspecified
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5) Gecko/20100101 Firefox/4.0b5
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

The aero on firefox breaks from time to time. It has happened to me on two different machines (both Windows 7 64bit). It doesn't always break for the same reason, but I have figured out a way which I think quite consistently breaks it. This has happened to me before Beta5 too, I think it has happened since the first beta. It happens both with HW-acceleration enabled and disabled.

Reproducible: Always

Steps to Reproduce:
1. Maximize Firefox
2. Connect/disconnect external monitor (probably works with resolution change too)

Actual Results:  
The aero theme is now broken, see screenshot.
(Reporter)

Comment 1

7 years ago
Created attachment 474677 [details]
Screenshots of how the broken aero looks
(Reporter)

Comment 2

7 years ago
Also, if I open a new window, that window will have working aero. See the screenshot, it shows two windows side by side, one broken and one working.
(Reporter)

Updated

7 years ago
Component: General → Theme
Hardware: x86 → x86_64
(Reporter)

Updated

7 years ago
Severity: major → normal
QA Contact: general → theme

Updated

7 years ago
Component: Theme → Graphics
Product: Firefox → Core
QA Contact: theme → thebes
blocking2.0: --- → ?
(Assignee)

Updated

7 years ago
Component: Graphics → Widget: Win32
Depends on: 545892
QA Contact: thebes → win32

Comment 3

7 years ago
This is almost certainly a dup of bug 545892, but we can check again when that's fixed. FWIW, I see this all the time also.
Assignee: nobody → jmathies
Status: UNCONFIRMED → NEW
blocking2.0: ? → final+
Ever confirmed: true
(Assignee)

Updated

7 years ago
Summary: Broken aero theme → Loss of aero glass after disconnect/connect of external monitor
(Assignee)

Comment 4

7 years ago
This may be fixed in tomorrow's nightly. I can't confirm however as I've not been able to reproduce.
(Assignee)

Updated

7 years ago
Duplicate of this bug: 606392

Comment 6

7 years ago
Does that pieces of bug https://bugzilla.mozilla.org/show_bug.cgi?id=545892 whit was landed fixed THIS bug?
(Assignee)

Comment 7

7 years ago
This should be fixed by the landings in bug 545892. Please reopen if you can reproduce in 10/28+ nightlies.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 8

7 years ago
This is happening in Firefox 5 now...
You need to log in before you can comment on or make changes to this bug.