If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

regression in bookmarks manager performance between 4.0b4 and 4.0b5

RESOLVED DUPLICATE of bug 595530

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 595530
7 years ago
7 years ago

People

(Reporter: AM, Unassigned)

Tracking

({qawanted, regression})

Trunk
x86
Mac OS X
qawanted, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

I have a recent imac computer, 4gb memory.

I have some 3000 bookmarks, many tagged.
I open "organize bookmarks" and type a tag with 10 matches.
On 4.0b4 the resulting bookmarks are on screen in less than one second.

in 4.05b nothing happens for three or four seconds, then the machine beach-balls
for several more seconds. It takes 6-8 seconds to find a bookmark.

Deleting a bookmark takes about 10 seconds in 4.05b, is fast in 4.0b4.

I checked in latest nightly- this is still slow-


Reproducible: Always

Steps to Reproduce:
1. open organize bookmarks
2. type a tag resulting in  10 results
3. very slow answer
Actual Results:  
Result is very slow

Expected Results:  
Older builds are faster
interesting, we would need a regression window to be able to find which patch could have caused that.
To make one, you could download nightly builds (mozilla-central nightlies are in ftp://ftp.mozilla.org/pub/firefox/nightly/) between 4.0b4 and 4.0b5 (so from 2010-08-19 on) and tell us which version shows the problem for first.
Keywords: qawanted, regressionwindow-wanted
also, please first ensure this is not due to an incompatible add-on by testing search in safe mode http://support.mozilla.com/kb/Safe+Mode
(Reporter)

Comment 3

7 years ago
Its between,

2010-08-26-03-mozilla-central/ fast
2010-08-26-09-mozilla-central/ slow




It did not change in safe mode
That'll be Range http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=75cc425bbaf0&tochange=bb8020341d71

There are Checkins done by you, Mak ;-)
URL: none
Keywords: regressionwindow-wanted → regression
Version: unspecified → Trunk
I know, but there's nothing there that could hit performances of search.
well apart the NativeInterface2JSObject change.
I can't reproduce the slowdown though with my profile.
(Reporter)

Comment 7

7 years ago
I just re-downloaded. I think I must have messed up naming one of the downloads

When I recheck I find it betwee
2010-08-25-03-mozilla-central/ fast
2010-08-26-03-mozilla-central/ slow

so one day earlier than I said
(Reporter)

Comment 8

7 years ago
This sounds a lot like 595530

Searching bookmarks and history is much slower after SQLite 3.7.x upgrade

though the date it becomes problematic on the mac is not the same as on
a windows machine
your new indication in comment 7 points at http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4a6ee9e82945&tochange=75cc425bbaf0
that has an upgrade to SQLite 3.7.1.

So yeah, it's same bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595530
You need to log in before you can comment on or make changes to this bug.