If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Overriding/replacing window icons from extension broken (at least for Thunderbird), documentation incorrect

VERIFIED DUPLICATE of bug 543490

Status

()

Core
Widget
VERIFIED DUPLICATE of bug 543490
7 years ago
6 years ago

People

(Reporter: aryx, Unassigned)

Tracking

1.9.2 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 474698 [details]
test extension overrides icon of main application window

Windows XP SP3 32-bit
Firefox 3.6.9
Thunderbird 3.1.3

Documentation: https://developer.mozilla.org/en/Window_icons

Trying to override the window icon of the application according to the documentation with the attached extension.
Works for Firefox with main-window.ico
Works not for Thunderbird with messengerWindow.ico

Notice: "These icons will override the global icon files, which are located in app_dir/chrome/icons/default." This is incorrect as this directory doesn't exist in Firefox 3.6.9.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543490
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.