revision.based_on is not set

VERIFIED FIXED in 2.3

Status

support.mozilla.org
Knowledge Base Software
P1
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: rrosario, Assigned: rrosario)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

(Assignee)

Description

7 years ago
When editing an article (default language/en-US), the new Revision should have based_on set to the Revision the edit was based on.
(Assignee)

Comment 1

7 years ago
landed yesterday:
http://github.com/jsocol/kitsune/commit/3f4882455e1de02dfec23faab0cb728d1c5a297c
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
How do I verify the based_on setting?
please update with test steps or a [qa-], thanks
Still needing QA steps or [qa-], thanks
I need to verify P1's asap
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

7 years ago
The only way to verify this right now is to:
1- Create and approve a new document.
2- Translate it and approve the translation.
3- Create a new revision of the en-US version and approve it.
4- Translate the new revision. 
5- On the translation review page, the top diff should show the two revisions from steps 1 and 3.

That said, I think that doesn't make sense. That diff should be the en-US revision the current translation is based on with the current approved en-US revision.

Marking this as [qa-].
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Whiteboard: [qa-]
Closed as [qa-]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.