All users were logged out of Bugzilla on October 13th, 2018

Integrate CyaSSL Embedded SSL Library

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: chris, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.55 Safari/534.3
Build Identifier: 

Hello,

I would like to bring attention to an embedded SSL library called CyaSSL.  I feel that CyaSSL would be an excellent fit for Fennec because of it's small size and speed which have been optimized for embedded devices. 

CyaSSL is an open source, C language based SSL library which is targeted at embedded and RTOS environments, primarily because of its small size and speed. It supports industry standards up to the current TLS 1.2 level.  For a size reference, CyaSSL is up to 20 times smaller than OpenSSL.

I feel that Fennec could greatly benefit from this addition as either a build option, or as a replacement for the existing NSS SSL library.  A full list of features can be viewed on the CyaSSL product page (http://yassl.com/yaSSL/Products_cyassl.html)

URL: http://www.yassl.com
License: Dual Licensed under GPLv2 and standard commercial licensing
Notes: Current version is 1.6.5

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Current version of CyaSSL is now 1.8.0 as of 12/23/2010
The link for the product page: http://yassl.com/yaSSL/Products-cyassl.html. 

The current version is 2.0.8 released on 02/24/2012.

Adding Arron and Mark in CC to make the decision if the enhancement would be feasible.
Status: UNCONFIRMED → NEW
Component: General → General
Ever confirmed: true
OS: All → Android
Product: Fennec → Fennec Native
Hardware: All → ARM

Updated

7 years ago
Component: General → Networking
Product: Fennec Native → Core
QA Contact: general → networking
WONTFIX for many reasons, but the license makes it impossible, AFAICT. Thanks for the offer though.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.