[D3D] Black areas for chrome and content on Windows XP under VMware

RESOLVED INVALID

Status

()

Core
Graphics
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: whimboo, Assigned: bas)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 474784 [details]
screenshot (windows 2000)

With recent nighly builds on mc we have black areas in chrome and content for builds running under vmware. I can reproduce it each time I start a Minefield build and especially on Windows 2000 it covers the whole browser (chrome and content) while on XP only chrome (toolbars) are affected. See the attached screenshot.

As talked with Joe, I will compact those vms and upload them to the file server.
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
(Reporter)

Comment 1

8 years ago
Would a regression range be helpful for you? AFAIR it goes back into August.
(Reporter)

Comment 2

8 years ago
An image of the Windows 2000 Vmware image you can find at:
http://fs.office.mozilla.org/public/QA/Henrik-D2D/

Comment 3

8 years ago
I'm seeing this on a non-VM, windows 7 pro box with hardware acceleration.  It began when I updated to the Sept. 14 nightly build, and is happening consistently.  When Firefox has focus, the aero glass is black.  When firefox does not have focus, aero glass is a gray color (i.e. not glass at all).  Default windows aero glass theme, no personas.
(Reporter)

Updated

8 years ago
Severity: normal → major
Summary: Black areas in chrome and content for VMWare images → Black areas for chrome and content
(Reporter)

Comment 4

8 years ago
This problem goes away when I don't use a default theme but i.e. Walnut:
https://addons.mozilla.org/en-US/firefox/addon/122/

Clint, can you confirm that?
Duplicate of this bug: 598801
(Reporter)

Comment 6

8 years ago
Bas or Joe, have you had time to check this issue with the VM image I have provided?
(Assignee)

Comment 7

8 years ago
(In reply to comment #6)
> Bas or Joe, have you had time to check this issue with the VM image I have
> provided?

We have, we had a try server build which fixed the issue with the VM but did not seem to help anyone experiencing this issue. We'll need to get our hands on a real box that exposes this behavior.
Henrik, can you upload or cause to be uploaded the Windows XP VM?
(Reporter)

Comment 9

8 years ago
(In reply to comment #8)
> Henrik, can you upload or cause to be uploaded the Windows XP VM?

Given by Bas in the comment before, isn't a native system what you need? Please clarify before I have to start again to prepare the VM, archive, and upload it. Thanks.
Even the VM might help, but if it's a lot of work let me get an install of XP up and running on a laptop I have at work to see if I can reproduce this problem.
(Reporter)

Comment 11

8 years ago
No, it's not a problem. The VM image can now be found under: http://fs.office.mozilla.org/public/QA/Henrik-D2D/

Please tell me if you need more information.
Assignee: nobody → bas.schouten
blocking2.0: ? → beta8+
Summary: Black areas for chrome and content → [D3D] Black areas for chrome and content on Windows XP
(Reporter)

Comment 12

8 years ago
Joe, do you have grabbed the VM? Can I remove it again from the fs?
Not yet. Bas will, I think, be grabbing it.
(Assignee)

Comment 14

8 years ago
(In reply to comment #11)
> No, it's not a problem. The VM image can now be found under:
> http://fs.office.mozilla.org/public/QA/Henrik-D2D/
> 
> Please tell me if you need more information.

I know have the VM image running, I installed the latest minefield and it seems to run beautifully with D3D9 support!
(Reporter)

Comment 15

8 years ago
(In reply to comment #14)
> I know have the VM image running, I installed the latest minefield and it seems
> to run beautifully with D3D9 support!

The latest Minefield build on XP seems to work pretty fine now. But on Windows 2000 we still get a complete black window. Even the title bar isn't visible. Moving the cursor around and clicking some points doesn't show the area behind it as what I have seen before. It simply keeps black. The build is absolutely not usable.
(Assignee)

Comment 16

8 years ago
(In reply to comment #15)
> (In reply to comment #14)
> > I know have the VM image running, I installed the latest minefield and it seems
> > to run beautifully with D3D9 support!
> 
> The latest Minefield build on XP seems to work pretty fine now. But on Windows
> 2000 we still get a complete black window. Even the title bar isn't visible.
> Moving the cursor around and clicking some points doesn't show the area behind
> it as what I have seen before. It simply keeps black. The build is absolutely
> not usable.

Yes, we will be blacklisting D3D9 for windows 2000.
(Reporter)

Comment 17

8 years ago
(In reply to comment #16)
> Yes, we will be blacklisting D3D9 for windows 2000.

Do we have a bug for that already?

Clint, what about your box? Is it also solved on your Win7 machine with the latest nightlies?

Comment 18

8 years ago
(In reply to comment #17)
> (In reply to comment #16)
> > Yes, we will be blacklisting D3D9 for windows 2000.
> 
> Do we have a bug for that already?
> 
> Clint, what about your box? Is it also solved on your Win7 machine with the
> latest nightlies?
That one time I saw it, Jeff M and I looked at it, then we restarted Firefox and it was never seen again. Still running windows nightlies, but I haven't seen it happen again.
(Reporter)

Comment 19

8 years ago
(In reply to comment #16)
> Yes, we will be blacklisting D3D9 for windows 2000.

Bas, please point me to a bug for that action. I think then we can close this bug as WFM.
(Assignee)

Comment 20

8 years ago
(In reply to comment #19)
> (In reply to comment #16)
> > Yes, we will be blacklisting D3D9 for windows 2000.
> 
> Bas, please point me to a bug for that action. I think then we can close this
> bug as WFM.

Bug 603204
(Reporter)

Comment 21

8 years ago
Thanks Bas. Now that we cannot reproduce the black box problem on XP anymore lets close this bug as WFM. Not sure which patch has been fixed it.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → WORKSFORME
(Assignee)

Comment 22

8 years ago
(In reply to comment #21)
> Thanks Bas. Now that we cannot reproduce the black box problem on XP anymore
> lets close this bug as WFM. Not sure which patch has been fixed it.

Most likely bug 593678.
(Reporter)

Updated

8 years ago
Depends on: 593678
Resolution: WORKSFORME → FIXED
(Reporter)

Comment 23

8 years ago
Sorry, but it's not fixed. I can still see it on our XP VM with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101023 Firefox/4.0b8pre
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 24

8 years ago
The strange thing is that it doesn't happen in safe mode. This profile doesn't have any extension installed, so this is kinda scary. Not sure what could be the reason for.
(Assignee)

Comment 25

8 years ago
(In reply to comment #24)
> The strange thing is that it doesn't happen in safe mode. This profile doesn't
> have any extension installed, so this is kinda scary. Not sure what could be
> the reason for.

In safemode hardware acceleration is disabled so that makes sense. Since this is in a VM on Mac I think we should open a separate bug for it for proper tracking. This more general problem is fixed I believe.
(Reporter)

Comment 26

8 years ago
(In reply to comment #25)
> In safemode hardware acceleration is disabled so that makes sense. Since this
> is in a VM on Mac I think we should open a separate bug for it for proper
> tracking. This more general problem is fixed I believe.

This bug was originally for the VMware issue we can see. It get slightly morphed. See the VM's I have offered you on this bug. Also bug 593678 looks more like the general issue. So I would propose to leave this bug open for remaining work.
Status: REOPENED → NEW
Summary: [D3D] Black areas for chrome and content on Windows XP → [D3D] Black areas for chrome and content on Windows XP under VMware
(Assignee)

Comment 27

8 years ago
(In reply to comment #26)
> (In reply to comment #25)
> > In safemode hardware acceleration is disabled so that makes sense. Since this
> > is in a VM on Mac I think we should open a separate bug for it for proper
> > tracking. This more general problem is fixed I believe.
> 
> This bug was originally for the VMware issue we can see. It get slightly
> morphed. See the VM's I have offered you on this bug. Also bug 593678 looks
> more like the general issue. So I would propose to leave this bug open for
> remaining work.

The VMs you gave still work fine. Presumably this is a problem for VMWare on Mac (which I don't have), I believe an issue with VMWare on Mac does not block beta8.
blocking2.0: beta8+ → ?
As long as Firefox in a VM still works, I don't think this needs to block, no. Is that the case?
(Reporter)

Comment 29

8 years ago
As what I have noticed. This box had an outdated VMware Fusion version installed. I have upgraded from 3.0.1 to 3.1.1 and re-installed the VMware tools. Now everything works fine. Lets close it as INVALID for now, but I will continue to watch that machine.
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
blocking2.0: ? → -
Keywords: regression
You need to log in before you can comment on or make changes to this bug.