Closed Bug 596121 Opened 14 years ago Closed 14 years ago

Rename Developer (tools) to Advanced Tools

Categories

(Firefox :: Menus, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 592622
Tracking Status
blocking2.0 --- beta7+

People

(Reporter: aicitman, Unassigned)

References

()

Details

(Keywords: uiwanted, Whiteboard: [strings])

User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b6pre) Gecko/20100913 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b6pre) Gecko/20100913 Firefox/4.0b6pre

quote from https://wiki.mozilla.org/User:Broccauley/Firefox_Menu_Explorations

Existing FF4 beta menus have a "Developer Tools" section.

"Character Encoding" is not necessarily a "Developer Tool". "Work Offline" isn't a "Developer Tool" at all. It is clearly a badly named sub-menu.

Renaming this sub-menu to "Advanced Tools" allows much more flexibility to allow anything that doesn't quite fit into another menu location to be placed here. It could also be a default location for add-ons. It also allows for unforeseen future menu expandability. 

Reproducible: Always




see bug 592622
Blocks: 583386
See Also: → 592622
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
See Also: 592622
I don't see why this would be a duplicate of bug 592622.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Requesting blocking since this may confuse people who need to change the character encoding or toggle offline mode as part of their normal browsing.

The character encoding item is important for a set of Asian locales, AFAIK. As for offline mode, when waking up my laptop it still happens from time to time that Firefox thinks it's not connected when other apps are.
blocking2.0: --- → ?
Whiteboard: [strings]
Blocking, but this might be a WONTFIX. Need to consider a bit more ...
blocking2.0: ? → beta7+
Keywords: uiwanted
So, both this bug *and* bug 592622 cannot block. Given my druthers, I think I prefer "advanced" to "developers" but I'm happy with whatever decision as long as we make it.
That menu is for Developer Tools — "Advanced Tools" is so non-descript as to be useless, in my opinion. 

I think the solution for the charset stuff is to pull it out to the top level for the 2-3 locales where it's seeing active use, and leave it for the developers everywhere else.
Bug 596173 covers the character encoding issue specifically, FWIW.
>Bug 596173 covers the character encoding issue specifically, FWIW

Yeah, the idea is that in cases where regularly users would need access to character encoding, it would be shown at a higher level, so they could still avoid going in to developer tools.
Okay - just talked with Faaborg and his opinion is also that, whether it ends up being Developer or Developer Tools over in byg 592622, it's not going to be "Advanced Tools."  --> WONTFIX
Status: NEW → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → WONTFIX
(In reply to comment #8)
> >Bug 596173 covers the character encoding issue specifically, FWIW
> 
> Yeah, the idea is that in cases where regularly users would need access to
> character encoding, it would be shown at a higher level, so they could still
> avoid going in to developer tools.

I think Gavin's point was that it doesn't cover Work Offline?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Also, as I understand it bug 596173 would need to be a beta7 blocker if it wants to add a locale pref.
Another cross reference: bug 593125 is going to tell the user to 'Uncheck "Work Offline"' but not how to get there, so it should be somehow discoverable in the menu. "Advanced" may be ambiguous and I'm not sure it's the best solution either, but "Developer" is plain misleading.
(In reply to comment #12)
> Another cross reference: bug 593125 is going to tell the user to 'Uncheck "Work
> Offline"' but not how to get there

Why not put an online/offline control directly within the content area where you get the offline error message? (or on the statusbar - cough!).

The point about "Advanced Tools" is not only to allow existing options to be encompassed, but it allows you the flexibility to add options in the future. MS uses the "Developer" tab in Office 2007+ to brush any options under the carpet that don't fit elsewhere - this never seemed quite right to me, as many of the add-ons and features there aren't really "developer"-specific.

You're going to need such an "under the carpet" location eventually; currently the "Tools" menu is used for this purpose, so how about simply naming it "Tools" instead?
(In reply to comment #13)
> (In reply to comment #12)
> > Another cross reference: bug 593125 is going to tell the user to 'Uncheck "Work
> > Offline"' but not how to get there
> 
> Why not put an online/offline control directly within the content area where
> you get the offline error message?

Technical limitation, I think (the error page isn't privileged).

"Tools" sounds ok to me, actually seems to fit better than in the menu bar.
OK, this is ridiculous. We have two bugs doing the same thing, and comments duplicated across them.

I *am* marking this a duplicate of the other bug, and morphing the other bug to be more comprehensive.
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.