meeting-notes blog feed sanitises video elements

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: robin, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b5) Gecko/20100101 Firefox/4.0b5
Build Identifier: 

Platform meeting notes usually have an attached HTML5 video element. This is being sanitised somewhere along the line to just write out the embed code.

Reproducible: Always

Steps to Reproduce:
1. Visit http://blog.mozilla.com/meeting-notes/archives/379
2. Look under the video section for a video
Actual Results:  
HTML code written to page.

Expected Results:  
A video.

Comment 1

8 years ago
This is probably due to html5lib.sanitizer. http://hg.mozilla.org/users/bsmedberg_mozilla.com/meeting-poster/file/dae080401851/post-meetings.py#l32

We probably either need to upgrade to a newer html5lib. I can't imagine the sanitizer is still stripping video elements.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.