Closed Bug 596181 Opened 9 years ago Closed 9 years ago

(re)starting firefox 4 beta 6 (candidate build 1) - all tabs windows empty (but url address bar displays urls) - no html content gets loaded and/or displayed

Categories

(Firefox :: Session Restore, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 588511

People

(Reporter: abittner, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.7 (KHTML, like Gecko) Chrome/7.0.517.5 Safari/534.7
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

i came across this odd behaviour already in the past, but only once, and i didnt have the time to report it back then.

situation: had/have firefox 4 beta 5 (windows xp) installed.
downloaded and installed beta 6 (candidate build 1) and installed it into separate directory for testing (\programfiles\ffx4beta6\).

using always the same firefox profile for both beta5 and beta6 installations.

started beta6 and bugzilla https://bugzilla.mozilla.org/show_bug.cgi?id=588511
still happened (maybe related to that?), and then beta6 started to create all the main firefox windows and tabs inside windows and firefox panorama aka tabcandy/tabgroups.

but all windows are empts content wise in the actual webpages display area or whatever you call that.

all addressbar lines are filled with their respective addresses, for example the firefox4 beta6 firstart/relnotes(?) webpage address etc in a new tab in one of the windows.



but everything is white. everything is blank. no actual webpages seem to get loaded.

with the help of microsoft/sysinternals process-explorer i think i viewed the tcp/ip information of the firefox.exe process and i have seen a great number of mozilla datacenter hostnames information, probably the plugin/extension compatibility checks, but nothing really anything else other than those http(s?) connections.


so the firefox probably never even attempted to connect to all my websites i have normally open in my windows and tabs. somehow the session restore of firefox went haywire and didnt finish or hangs or broke off somewhere in the middly.

i still can create new empty tabs and enter urls there and visit new sites, and i can also press enter/resubmit the displayed urls for all those emtpy tabs in the url address location area and make the pages load manually.

weird.

Reproducible: Sometimes

Steps to Reproduce:
1. cannot tell how to exactly repro this behaviour
2. maybe have an older ffx4 beta N-1 build, and install a parallel beta N build
3. via the installer.exe package downloaded from the beta web/ftp servers.



about:buildconfig
Source

Built from http://hg.mozilla.org/mozilla-central/rev/6064b6dae4fe
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\win32_build\build\build\cl.py cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\win32_build\build\build\cl.py cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd4800 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
Configure arguments

--enable-application=browser --enable-update-channel=beta --enable-update-packaging --enable-jemalloc --enable-tests --enable-official-branding
Component: General → Session Restore
Version: unspecified → Trunk
QA Contact: general → session.restore
(In reply to comment #0)
> started beta6 and bugzilla https://bugzilla.mozilla.org/show_bug.cgi?id=588511
> still happened (maybe related to that?), and then beta6 started to create all
> the main firefox windows and tabs inside windows and firefox panorama aka
> tabcandy/tabgroups.

This sounds exactly like behavior that is connected to that bug, which will be a part of beta 7. It landed in mozilla-central nightlies, so if you're interested in testing those build, that would be helpful.

FWIW, quitting and starting Firefox again from that broken state should work just fine, it's just that all network activity is broken.
Please reopen if it still happens in builds with bug 588511 fixed.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 588511
You need to log in before you can comment on or make changes to this bug.