browser.history_expire_days is no longer respected

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: c221752, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre

There's no way to restrict the number of days Firefox keeps history. It's hard-coded to 180 days, and browser.history_expire_days in about:config is not respected anymore. IMHO this option is important enough to even consider putting it in the GUI, like in IE. 

Reproducible: Always
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

8 years ago
the option browser.history_expire_days doesn't exists in about:config. Even if I add it manually, it erased after I restart Firefox.
This is intended due to internal Changes what makes that Pref of no Use anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Actually WONTFIX because we specifically changed it in bug 520165.
Resolution: INVALID → WONTFIX
You need to log in before you can comment on or make changes to this bug.