jsbridge should not include debug addons out of the box

VERIFIED DUPLICATE of bug 602284

Status

Testing Graveyard
Mozmill
VERIFIED DUPLICATE of bug 602284
8 years ago
2 years ago

People

(Reporter: Jeff Hammel, Unassigned)

Tracking

Details

(Whiteboard: [mozmill-2.0+])

(Reporter)

Description

8 years ago
jsbridge currently has convenience debug addons:

http://github.com/mozautomation/mozmill/tree/master/jsbridge/jsbridge/xpi/

This is bad for a few reasons:

 - having these extensions means that you're not testing OOTB firefox, you are testing firefox with these extensions

 - these extensions need to be updated manually

 - these extensions should be removed manually before rolling into mozilla central

While there is convenience gained by the user in having these extensions available, we should find a way to provide this convenience without having these binary extensions replicated in our tree.
(In reply to comment #0)
>  - having these extensions means that you're not testing OOTB firefox, you are
> testing firefox with these extensions

Those extensions get only installed when you run mozmill with the --debug option which is not used per default.

>  - these extensions need to be updated manually

Right, that's really annoying.

>  - these extensions should be removed manually before rolling into mozilla
> central

Well, that action will happen really rarely. Instead - I can only talk for myself - I'm using --debug really often to debug issues in a fresh profile.

> While there is convenience gained by the user in having these extensions
> available, we should find a way to provide this convenience without having
> these binary extensions replicated in our tree.

Something I would be ok with, is when I could specify a local folder which has all the add-ons I want to have for debugging. All of those should be installed. I would assume --addons works already for this.

Comment 2

8 years ago
(In reply to comment #1)
> (In reply to comment #0)

> Something I would be ok with, is when I could specify a local folder which has
> all the add-ons I want to have for debugging. All of those should be installed.
> I would assume --addons works already for this.

Yes, I believe that is the entire point of --addons.
Component: JSBridge → Mozmill
QA Contact: jsbridge → mozmill
(Reporter)

Comment 3

7 years ago
This should go in 2.0 if its not done already
Whiteboard: [mozmill-2.0?]

Updated

7 years ago
Whiteboard: [mozmill-2.0?] → [mozmill-2.0+]
fixed by bug 602284
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 602284
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.