Support for display of Outlook meeting requests, appointments, etc

RESOLVED FIXED in Lightning 0.3

Status

Calendar
Lightning Only
--
enhancement
RESOLVED FIXED
18 years ago
12 years ago

People

(Reporter: Erik Talvola, Unassigned)

Tracking

unspecified
Lightning 0.3
Dependency tree / graph

Details

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
Bug 32629 talks about implementing a full calendar system within Netscape 
Mail.  One thing which would be a potential first step, or a side project, 
would be to recognize the special e-mails that Outlook uses for certain items.

All of these seem to just include special text in the body of the e-mail which 
the Outlook client must use.

Appointment and meeting requests are the ones that would be most useful.  There 
are some other things, like Tasks, which might also be useful.

Appointment or Meeting Request (they seem to be identical):

From: Erik Talvola <etalvola@sapient.com>
To: "'talvola@sdf.lonestar.org'" <talvola@sdf.lonestar.org>
Subject: Test appointment
Date: Thu, 9 Nov 2000 13:54:07 -0500
Content-Type: text/plain;
        charset="iso-8859-1"

When: Thursday, November 09, 2000 11:00 PM-11:30 PM (GMT-08:00) Pacific Time
(US & Canada); Tijuana.
Where: San Francisco

*~*~*~*~*~*~*~*~*~*

In Netscape mail - you can read the When and Where just fine, but in Outlook
clients, you are presented with buttons allowing 'Accept', 'Tentative', and
'Decline', which send pre-formatted replies.  If you can't send those messages,
then you can't effectively use Netscape mail in an Outlook environment.

Not sure if all the details of the formats are documented or not.

Of course, this is just Outlook.  Lotus Notes has its own format for sending 
out meeting requests, and I'm sure there are many other standards as well.

Comment 1

18 years ago
Reporter is this still a problem in the latest nightlies?
(Reporter)

Comment 2

18 years ago
Yep - nothing has changed recently here.  Build ID: 2000121804

Comment 3

18 years ago
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
Blocks bug 122651 and bug 122652.
Blocks: 122651, 122652

Comment 5

17 years ago
would anyone be upset if I took over this bug in the calendar app?  My goal is
to eventually getting to the point where calendar and mailnews can do this
together.  Since this bug hasn't been commented on (except to block the calendar
mailnews tracking bug) I assume this won't be a big deal.

Comment 6

17 years ago
reassigning to danp@oeone.com.  I'm reassigning to Dan.
Assignee: putterman → danp

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 7

16 years ago
I am afraid this bug, or the solution to it is invalid.
Outlook does *not* parse the text as an calendar entry, the text is only the 
text/plain part of a multipart-mime message where the calendar data is stored 
in a MAPI storage part. So setting the text has no effect on Outlook.

Part of the actual message:

This is a multi-part message in MIME format (send by a Dutch Outlook 2002 
client):

------=_NextPart_000_0005_01C23427.CB2CB970
Content-Type: text/plain;
	charset="Windows-1252"
Content-Transfer-Encoding: 7bit

Tijd: Saturday, August 10, 2002 9:00 AM-9:30 AM (GMT+01:00) Amsterdam,
Berlin, Bern, Rome, Stockholm, Vienna.

*~*~*~*~*~*~*~*~*~*



------=_NextPart_000_0005_01C23427.CB2CB970
Content-Type: application/ms-tnef;
	name="winmail.dat"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
	filename="winmail.dat"

eJ8+IhcUAQaQCAAEAAAAAAABAAEAAQeQBgAIAAAA5AQAAAAAAADoAAEIgAcAHgAAAElQTS5NaWNy
b3NvZnQgU2NoZWR1bGUuTXRnUmVxAJUKAQ2ABAACAAAAAgACAAEGAAMADgAAANIHCAAKAAkAAAAA
AAYA+gABBwADAA4AAADSBwgACgAJAB4AAAAGABgBAQgABQAEAAAA0ncZ4kQCAQkABAACAAAAAQAB
AAEGgAMADgAAANIHBwAZABYACAAAAAQAGwEBA5AGANwMAABcAAAACwACAAEAAAALACMAAAAAAAMA
JgAAAAAACwApAAAAAAADAC4AAAAAAAMANgAAAAAAHgBNAAEAAAABAAAAAAAAAEAAYAAAGA6LO0DC
AUAAYQAATPC7P0DCAR4AcAABAAAACAAAAHRlc3QxMjMAAgFxAAEAAAAWAAAAAcI0Fwd7FLNF9841

(Reporter)

Comment 8

16 years ago
hmm - I know about the MS-TNEF attachments, but I never actually see them in 
Mozilla Mail on Calendar entries.   This could very well be the same issue as 
Bug 59627 - where simply using IMAP to get information from an Exchange Server 
is not sufficient - and to really get all of the information visible with the 
Outlook client, one needs to use MAPI, or something like the Ximian Connector 
(http://www.ximian.com/products/connector/).


If it is matter of extracting info from a TNEF file, there is a GPL application 
called TNEF at http://sourceforge.net/projects/tnef/ which can handle it.

Comment 9

16 years ago
Tried that, but sadly extracting the attachment with 
http://sourceforge.net/projects/tnef/ does not work. So that won't solve the 
problem.

Comment 10

16 years ago
I never receive calendar data from outlook clients as ms-tnef attachment.
I receive instead ics file in UTF-8, so it looks a lot easier to integrate to
the calendar, in fact it sound as if we only require for the type text/calendar
to trigger the calendar.
But maybe the current calendar doesn't support all the fields used.

Here is what I get exatly (a few of the HTML as been trimmed):

This is a multi-part message in MIME format.

------_=_NextPart_001_01C19E77.DC6F3BFE
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Diso-8859-1">
<META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
6.0.4712.0">
<TITLE>Mis(e) =E0 jour: Point teleIR</TITLE>
</HEAD>
<BODY>
<!-- Converted from text/rtf format -->

<P><SPAN LANG=3D"fr-lu"><FONT SIZE=3D2 FACE=3D"Arial">Quand=A0: jeudi 17 =
janvier 2002 15:30-16:30 (GMT+01:00) Brussels, Copenhagen, Madrid, =
Paris.</FONT></SPAN>

<BR><SPAN LANG=3D"fr-lu"><FONT SIZE=3D2 FACE=3D"Arial">Emplacement=A0: =
Issy</FONT></SPAN>
</P>

<P><SPAN LANG=3D"fr-lu"><FONT SIZE=3D2 =
FACE=3D"Arial">*~*~*~*~*~*~*~*~*~*</FONT></SPAN>
</P>

<P><SPAN LANG=3D"fr-lu"><FONT COLOR=3D"#0000FF" SIZE=3D2 =
FACE=3D"Arial">Peut on d=E9caller le point propos=E9 par J=E9rome =E0 =
jeudi apr=E8s midi apr=E8s 15H30</FONT><FONT FACE=3D"Times New Roman"> =
</FONT></SPAN>

<BR><SPAN LANG=3D"fr-lu"><FONT COLOR=3D"#0000FF" SIZE=3D2 =
FACE=3D"Arial">En effet je suis =E0 l'ext=E9rieur demain =
matin</FONT><FONT FACE=3D"Times New Roman"> </FONT></SPAN>

------_=_NextPart_001_01C19E77.DC6F3BFE
content-class: urn:content-classes:calendarmessage
Content-Type: text/calendar;
	method=REQUEST;
	name="meeting.ics"
Content-Transfer-Encoding: 8bit

BEGIN:VCALENDAR
METHOD:REQUEST
PRODID:Microsoft CDO for Microsoft Exchange
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Sarajevo/Warsaw/Zagreb
X-MICROSOFT-CDO-TZID:2
BEGIN:STANDARD
DTSTART:16010101T030000
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
RRULE:FREQ=YEARLY;WKST=MO;INTERVAL=1;BYMONTH=10;BYDAY=-1SU
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:16010101T020000
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
RRULE:FREQ=YEARLY;WKST=MO;INTERVAL=1;BYMONTH=3;BYDAY=-1SU
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
DTSTAMP:20020116T102646Z
DTSTART;TZID="Sarajevo/Warsaw/Zagreb":20020117T153000
SUMMARY:Mis(e) Ã  jour: Point IR
UID:040000008200E00074C5B7101A82E00800000000B0F8BF3EE39DC101000000000000000
 010000000CD83D38905AC2B4290EC0F81EF827F84
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;RSVP=TRUE;CN="Ea(E-mail)":MAILTO:ea@test.invalid
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;RSVP=TRUE;CN="Jean-Marc
  Desperrier (E-mail)":MAILTO:jean-marc.desperrier@test.invalid
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;RSVP=TRUE;CN="Ph
(E-mail)":MAILTO:ph@test.invalid
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;RSVP=TRUE;CN="Br
(E-mail)":MAILTO:br@test.invalid
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;X-REPLYTIME=20020116T08
 0800Z;RSVP=TRUE;CN="Fr":MAILTO:fr@test.invalid
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;RSVP=TRUE;CN="La
(E-mail)":MAILTO:la@test.invalid
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;RSVP=TRUE;CN="Do
(E-mail)":MAILTO:do@test.invalid
ATTENDEE;ROLE=OPT-PARTICIPANT;PARTSTAT=NEEDS-ACTION;X-REPLYTIME=20020115T18
 2100Z;RSVP=TRUE;CN="Do":MAILTO:do@test.invalid
ORGANIZER;CN="Je":MAILTO:je@test.invalid
LOCATION:Issy
DTEND;TZID="Sarajevo/Warsaw/Zagreb":20020117T163000
DESCRIPTION:Peut on décaller le point proposé par Jérome à jeudi après
  midi après 15H30 \NEn effet je suis à l'extérieur demain matin \NMerci
 \N\N
SEQUENCE:0
PRIORITY:5
CLASS:
CREATED:20020116T102338Z
LAST-MODIFIED:20020116T102339Z
STATUS:CONFIRMED
TRANSP:OPAQUE
X-MICROSOFT-CDO-BUSYSTATUS:BUSY
X-MICROSOFT-CDO-INSTTYPE:0
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-IMPORTANCE:1
BEGIN:VALARM
ACTION:DISPLAY
DESCRIPTION:REMINDER
TRIGGER;RELATED=START:-PT00H15M00S
END:VALARM
END:VEVENT
END:VCALENDAR

------_=_NextPart_001_01C19E77.DC6F3BFE--
(Reporter)

Comment 11

16 years ago
Outlook 2000 (at least) supports sending calendar items either in 'native' 
Exchange server format, or as iCalendar messages 
(http://www.ietf.org/rfc/rfc2445.txt).   However, that is not the default, and 
for users in many corporations, they will likely never see iCalendar formatted 
messages.
I believe there is some Linux app (Evolution or some other) that has done just
what we need, namely to send and recieve "outlook items" by just using plain
imap and not doing their special outlook to exchange protocol.

Perhaps it was worth a look, if we are lucky it is open source
*** Bug 151240 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
Changing this to a calendar bug, because its calendar that's going to have to
overlay email.
Component: Mail Window Front End → Calendar Front End
Product: MailNews → Calendar
Target Milestone: --- → 1.1
Version: other → unspecified

Comment 15

16 years ago
*** Bug 172611 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
Don't we want this to work on all platforms and OSes? Platform/OS -> All/All!
OS: other → All
Hardware: PC → All
Some context / data which may or may not help - I have poked around with this a lot.

1. TNEF is a propetary, binary MS attachment packing format, that dates from the
dawn of time. It can handle multiple parts, much like MIME. 

2. When Outlook sends stuff in TNEF, it packs all the parts up as one TNEF
bundle, inclduing the HTML version of the email text, and then sends a two
section MIME mutlipart with text/plain (the text version) and
application/ms_tnef (the TNEF bundle). The filename of the TNEF bundle within
the MIME layer is always "winmail.dat".

3. When Outlook sends mail via an Exchange Server (or at least, when using the
proprietary MAPI connector), the server repacks TNEF into MIME for the external
network. That doesn't help if you are using Outlook standalone on a small
network with simple SMTP and e.g. sendmail as the server, or using it standalone
from a home office with an ISP's mail server.

4. When Outlook sends normal attachments, the default packing is multipart with
base64 for the binaries, unless you select RTF as the formatted text format
(instead of HTML) - this triggers an unrelated feature which changes attachment
packing to the TNEF bundle described above. There is no explicit UI for
controlling TNEF vs MIME.
  
5. When Outlook sends calendaring requests, by default they are always sent as
TNEF, unless you turn on an option which sends them in iCAL format. The problem
is, most people neither know nor care that this exists; Outlook users are
accustomed to sending these meeting request emails and having them simply work.

6. Even if iCAL is selected, Outlook (at least, the Office 2k version) will
still use TNEF for meeting requests if there are any other attachments, e.g. a
binary file like and MS-Word document. It seems unwilling or unable to pack an
iCAL with other attachments in MIME, though AFAICT there are no technical or
standards obstacles to doing so.


--


IMHO, to truly be useful, here are the features that a Mozilla integrated
calendaring support must have. I'm not trying to sound demanding, this is just
an objective opinion and no more valid than anyone else's. 

I will say the calendar is the "killer feature" that enabled MS to migrate
corporate clients from Lotus Notes + Domino to Outlook + Exchange, and it is the
killer feature, which, when in Mozilla, will enable me to displace Outlook
entriely from the non-techie side of my organization and all the accursed
viruses with it. I will *love* whoever provides this :-)

As previous comments point out, taking the moral high ground (iCAL is standard,
MS should use it) is of no value to users of Mozilla - the unwashed public uses
Outlook in its default install, and spews forth TNEF onto the internet. I get
TNEF meeting thingies every day, from both within and outwith the company. Just
like any word processor which doesn't handle .doc is a waste of time, if you
want interoperability with Outlook you have to bring Mohammed to the mountain,
and that means working with whatever Outlook produces (proprietary or otherwise)
in its default install configuration.

1. Mozilla needs to understand TNEF as well as MIME. Ideally, this feature
should be modular, and completely independent of the calendaring; all the usual
attachment handling should work (Save As, Inline Display, etc.) Open source
tools exist which unpack TNEF suitable for reference source, e.g.

http://freshmeat.net/projects/tnef/?topic_id=28

2. Having unpacked the MIME, Mozilla needs to understand the calendaring
attachment. This is no doubt binary :-) Other tools exist which do this too,
e.g. Ximian Evolution.

3. Add a feature which detects if a TNEF bundle contains a meeting request, and
like Outlook, offers a different UI presentation with the action buttons
(Reject, Confirm, etc.) embedded in a toolbar above the message pane. 

This would eventually be integrated with a future Mozilla PIM tool, and e.g. add
it to the PIM's calendar in the usual way.

Pressing the buttons should generate appropriate replies in (configurable)
either iCAL or TNEF, or in the same format as was received (Outlook speaks very
fluent iCAL and I've had an Outlook user on it for 6 months, interoperating with
Outlook-TNEF users without even realising it).



 

Comment 18

16 years ago
from my experience, MS Outlook can pack attached files in a winmail.dat file.
This happens only when ht eoptions are set to send message in RTF format (and
not SimpleText ou HTML).
A workaround is to tell the sender to switch to "Simple text". The sender, when
writing a mail, will still be able to choose the HTML format, and thus format
the message with plenty of colors. If the sender does so, the attached files
will be in MIME, and can be read by any RFC-compliant mail application that
receives the mail.

Comment 19

15 years ago
I stumbled across Rainlendar http://vapaa.dc.inet.fi/~rainy/ which is a small
desktop calendar utility that nicely displays outlook appointments, meeting,
etc.... Have a look at the utility, also available with source code, under GNU
GPL. Perhaps we can reuse come of that code? (posted same comment in bug 134763
by the way).

Comment 20

15 years ago
This is one of two bugs (Bug 134763) that I've found for Exchange calendar
support [should one dupe?].  Comment 17 and Comment 19 seem to outline the
necessary information for interaction formats. In my personal experience in
trying to get corporate users to switch to Mozilla / Thunderbird, the greatest
boundary has been integration with Exchange Calendaring. I'm confused over the
lack of resources directed toward this issue. If this issue were addressed, it
seems like it would greatly increase the usage of Moz as calendaring / invitees
are so central in many exchange installs. What can be done to increase the
importance of this issue and resolution time?

Comment 21

15 years ago
*** Bug 237904 has been marked as a duplicate of this bug. ***

Comment 22

15 years ago
Hi!

I see this bug has not had any activity in a while.  Let me describe my setup
and ask whether I should file my inquiry under this bug or open a new one.

I am using Thunderbird 0.5 with Calendar 2004022612-cal as reported in Help ->
About Calendar.  Thunderbird is connecting to an Exchange 2000 server (not my
choice) via IMAP.  When I receive meeting requests and appointments from Outlook
users, the messages look very much like those described below in "Additional
Comment #10 From Jean-Marc Desperrier  2002-08-28 12:57 PST".  There is an
initial text/html part describing for the user the "where" and "when" attributes
("quand" and "emplacement" in Jean-Marc's example).  Next is a text/calendar
part.  I never see this second part represented as an attachment.  There is in
fact no indication of its presence except by viewing the source of the message:

------_=_NextPart_001_01C415B4.178BE820
content-class: urn:content-classes:calendarmessage
Content-Type: text/calendar;
	method=REQUEST;
	name="meeting.ics"
Content-Transfer-Encoding: 8bit

I suspect that there is either a violation of the RFCs on Exchange's part or a
MIME parser bug on Mozilla's part (being equitable here) as I can make the
text/calendar part show up by minimal tweaking:

------_=_NextPart_001_01C415B4.178BE820
Content-Type: text/calendar;
        method=REQUEST;
        name="meeting.ics"
content-class: urn:content-classes:calendarmessage
Content-Transfer-Encoding: 8bit

Here I have rearranged the MIME headers for the text/calendar part so that the
Content-Type header comes first.  I don't know whether the MIME RFCs dictate
this ordering, but making this change causes Thunderbird to display the attachment.

Comment 23

14 years ago
Created attachment 147649 [details]
E-mail with attached image

Source of any e-mail that does not work. This is not a vcalendar attachement,
but is generated by Outlook and received by Mozilla. Note image in attachment
is copyrighted, and is present as the e-mail was sent to me. Addresses have
been changed.

Comment 24

14 years ago
It appears that this does not just affect vcalendar type attachments. Today I
recevied an e-mail ( see first attachment - 'e-mail.txt' ) and it suffers from
the same problem, ie. it does not appear in the view frame or as an attachement.
For those of you who don't want to download the whole attachement (though it
might prove more useful than the MIME section byitself) the start of the MIME
sections looks like:

------_=_NextPart_001_01C431FF.E75E9C0C
Content-Type: image/gif;
	name="dilbert2073207040504.gif"
Content-Transfer-Encoding: base64
Content-Description: dilbert2073207040504.gif
Content-Location:
http://www.dilbert.com/comics/dilbert/archive/images/dilbert2073207040504.gif

R0lGODlhWALNALMAAMvLy/Ly8qampvr6+oODgywsLLm5uZaWlnZ2dmZmZurq6ldXV93d3UVFRQAA
AP///yH5BAAAAAAALAAAAABYAs0AAAT/8MlJq7046827/2AojmRpnmiqrmzrvnAsz3Rt33iu73zv
/8DUQEAsGo/IpHLJbDqf0Kh0Sq0OOIaqdsvter/gJYMDCJvP6LSaaaAEHPC4fE6v2+/4vH7P7/v/

Comment 25

14 years ago
From http://www.novell.com/products/connector

Effective immediately, Evolution Connector for Microsoft Exchange Server
2000/2003 (formerly Ximian Connector) is available under a free, open source
license. Users no longer need a license file to run the software, and source
code has been made public at http://ftp.ximian.com under the terms of the GNU
General Public License (GPL).

Comment 26

14 years ago
*** Bug 252576 has been marked as a duplicate of this bug. ***

Comment 27

14 years ago
Playing around with the text of an Outlook message shows that the problem is due
to Outlook using the 'multipart/alternative' mime type to specify the e-mail
content. An explanation of the mime-type is available here:

  http://www.freesoft.org/CIE/RFC/1521/18.htm

Specifically: "The multipart/alternative type is syntactically identical to
multipart/mixed, but the semantics are different. In particular, each of the
parts is an "alternative" version of the same information."

Changing the mime-type to 'multipart/mixed' gets the attachment displayed, but
only because the semantics are changed. What would be needed is for Mozilla to
provide access to the 'alternative' presentations of the text, maybe via a menu
or a list. 

If you think about it, the mime-type is actually correct (the practical side is
a separate argument). Mail clients that don't know how to deal with
'text/calendar' will default to the 'text/html' or 'text/palin' description of
the appointment. Clients, such as Outlook, that understand the mime-type will
give precedence to it and display it with the appropriate viewer.

If you do a search in Bugzilla for 'multipart/alternative' you will see that
there are already a number of entries related to the MIME type.

Comment 28

14 years ago
See bug 130119 for a request to fix the 'multipart/alternative' issue, which
affects this bug.

Updated

14 years ago
Depends on: 130119

Comment 29

14 years ago
*** Bug 258393 has been marked as a duplicate of this bug. ***
*** Bug 227923 has been marked as a duplicate of this bug. ***
mostafah should have been CC'ed when this became a calendar bug

Comment 32

14 years ago
I am using Thunderbird 0.9 and daily build of Calendar extension. 
Here is how I get meeting info from my co-workers using Outlook 2003 with iCal
enabled by default:

MIME-Version: 1.0
Content-Type: text/calendar; method=REQUEST;
	charset="utf-8"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook, Build 10.0.2627
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1409
Importance: Normal
X-UIDL: +bD"!<pQ!!mRN!!YCS"!

BEGIN:VCALENDAR
PRODID:-//Microsoft Corporation//Outlook 10.0 MIMEDIR//EN
VERSION:2.0
METHOD:REQUEST
BEGIN:VEVENT

So, it's not multipart/alternative... Did Outlook change its format?

Comment 33

14 years ago
(In reply to comment #32)
> I am using Thunderbird 0.9 and daily build of Calendar extension. 
> 
> So, it's not multipart/alternative... Did Outlook change its format?

My colleagues seem to be using a later version of Outlook. I just wanted to
confirm this version is not sending calendar events as multipart, as well.

Here's the snippet...

MIME-Version: 1.0
Content-Type: text/calendar; method=REQUEST;
	charset="utf-8"
Content-Transfer-Encoding: 7bit
X-Mailer: Microsoft Office Outlook, Build 11.0.5510
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1409
Thread-Index: AcUHfjg19mBrvYwdSZCtlgnMkUPL2A==

BEGIN:VCALENDAR
PRODID:-//Microsoft Corporation//Outlook 11.0 MIMEDIR//EN
VERSION:2.0
METHOD:REQUEST
BEGIN:VEVENT

Comment 34

13 years ago
Created attachment 194878 [details]
Sample Outlook invitation (text/calendar, not winmail.dat)

Comment 35

13 years ago
The dependency on bug 130119 should be dropped, because there's no requirement
to manually present the text/calendar part of a multipart/alternative to the
user (which is what 130119 asks for).  What needs to happen is just that
Thunderbird parses vCalendar data in text/calendar MIME parts automatically, and
presents the appropriate UI elements to the user (Accept, Tentative, etc.).  

Note that Outlook offers a particularly useful feature where all invitations, on
being parsed in the Inbox, are automatically added to the calendar as Tentative
until the user chooses to accept or decline.  That way, if you get behind on
your mail, but check your calendar, you won't miss meetings that you haven't
accepted yet.

Being able to parse winmail.dat can be split off as a later enhancement, as
Outlook 2003 in IMAP mode and when connecting to Exchange 5.5 or 2003 now sounds
text/calendar MIME types rather than winmail.dat (see new attachment).

Is anyone working on automated parsing of text/calendar.  The Mozilla Calendar
extension seems mature enough to be ready for the integration.

Comment 36

13 years ago
Created attachment 194883 [details]
Screenshot of Outlook meeting invitation UI

This screenshot shows the UI for an Outlook meeting invitation.  (It's shown
here in the preview pane, but it looks the same in it's own message window). 
The key buttons are Accept, Tentative, Decline, Propose New Time, and
Calendar....  The last opens the Calendar in a new window, with this event
highlighted (the event is marked tentative until the user manually selects an
option).  This UI works extremely well and should be replicated in Thunderbird.

Updated

13 years ago
Component: Sunbird and Calendar-Extension Front End → Base
Priority: P3 → --
QA Contact: esther → base
Target Milestone: 1.1 → Future

Comment 37

13 years ago
It would also be nice if it would set the appropriate meeting status to cancelled when you import a meeting cancelation request for a meeting you already have scheduled.  This may be part of duplicate filtering, but it relates to this bug.  I can attach a sample of a meeting cancellation if necessary.


I also have a workaround for the multipart/alternative not displaying issue.  I use the following lines in my .procmailrc to change them to multipart/mixed:

:0 wf
*^content-class: urn:content-classes:calendarmessage
| perl -p -e's@(Content-Type: multipart/)alternative;@$1mixed;@'

Comment 38

13 years ago
(In reply to comment #35)
> Note that Outlook offers a particularly useful feature where all invitations, on
> being parsed in the Inbox, are automatically added to the calendar as Tentative
> until the user chooses to accept or decline.  That way, if you get behind on
> your mail, but check your calendar, you won't miss meetings that you haven't
> accepted yet.

Where I work I get loads of event anouncements and the fact that they all show on my calendar is very annoying, since it keeps me from noting the important stuff (perhaps I'm just an unskilled outlook user, but I don't know how to get rid of all these events in my view). Anyway, just wanted to say that if this suggestion is implemented, then I think there should also be a way to view the calander with the tentative-appointments-from-emails cleared.

Updated

12 years ago
Assignee: danp → nobody
Status: ASSIGNED → NEW

Comment 39

12 years ago
============================================================================
When: Occurs every Wednesday effective 15-Feb-06 from 10:00 AM to 12:00 PM
(GMT+05:30) Calcutta, Chennai, Mumbai, New Delhi.
Where: 4th floor room

*~*~*~*~*~*~*~*~*~*

On behalf of XYZ:

we will start discuss AIs 
==========================================================
The outlook comes with this message. I am a novice in mozilla (cant add myself!!), but as this is a common format i think it would be easier to extract date, time and place and associate it with the lightning calender ical format. This as discussed earlier by others would be useful feature so as to completly move out of outlook.
Dupe of 334468 now since that landed?
Component: Internal Components → Lightning Only
QA Contact: base → lightning
Target Milestone: Future → Lightning 0.3

Updated

12 years ago
Target Milestone: Lightning 0.3 → Lightning 0.5
Created attachment 242256 [details]
screenshot of Tbird+Ln reading the message

As seen in this screenshot, this bug is (finally) FIXED by ctalbert's iMIP stuff.
FIXED by checkin for bug 343049
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Depends on: 343049
Resolution: --- → FIXED
Target Milestone: Lightning 0.5 → Lightning 0.3
You need to log in before you can comment on or make changes to this bug.