remove the try_ssl code, it's auth_method only now.

VERIFIED INVALID

Status

MailNews Core
Networking: SMTP
P3
normal
VERIFIED INVALID
17 years ago
9 years ago

People

(Reporter: Jarrod Gray, Assigned: scottputterman)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I have my smtp try_ssl pref set to 2, which should make smtp always use ssl to 
send mail. I sniffed my packets and there was no ssl transaction - everything 
went through plain text. I did the same thing with NS4.75 and the packets showed 
the ssl transaction.

I'm running
Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001109
a trunk build.

Comment 1

17 years ago
What pref name are you using? The pref has been changed. Try the following and
let me know if this fix your problem.

user_pref("mail.smtpserver.smtp1.auth_method", 3);

0 -- no auth
1 -- auth any
2 -- auth login
3 -- try ssl/tls
4 -- ssl/tls only
(Reporter)

Comment 2

17 years ago
I am using try_ssl because of what I've seen here in nsSmtpProtocol.h. It looks
to me that by using auth_method I would be requesting to use TLS and not SSL.

 89 typedef enum _PrefAuthMethod {
 90 PREF_AUTH_NONE = 0,
 91 PREF_AUTH_ANY = 1,
 92 PREF_AUTH_LOGIN = 2,
 93 PREF_AUTH_TLS_TRY = 3,
 94 PREF_AUTH_TLS_ONLY = 4
 95 } PrefAuthMethod;
 96
 97 typedef enum _PrefTrySSL {
 98 PREF_NO_SSL = 0,
 99 PREF_TRY_SSL = 1,
100 PREF_ALWAYS_SSL = 2
101 } PrefTrySSL;

Comment 3

17 years ago
PrefTrySSL is 4.7 enum which should go away. TLS is a synonum to SSL.
I've told jeff that I'll take care of removing the try_ssl stuff.

updating summary, taking bug from jeff.

the only concern I have before I do that is migration.  I'm working on that
issue and I'll have it resolved soon.
Assignee: jefft → sspitzer
Summary: ssl smtp not reading pref → remove the try_ssl code, it's auth_method only now.

Comment 5

17 years ago
Is the reporter's case valid in that this is a bug? Hence is it confirmed, or 
invalid?
Seth: seeing how you took the bug for yourself.. does that mean you can confirm 
it?

Comment 6

17 years ago
Marking INVALID due to lack of response. Reopen if its still a problem in the
latest nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
reopening.

this issue still needs to be investigated.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 8

17 years ago
well, seth, would you like to confirm it?
confirming.

putterman, who'd we give the SMTP / SSL ui issue to?

they should get this one, too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 10

17 years ago
what's the actual bug here? Is it not working even with jefft's suggestion, or
is this just to remove an unused enumeration?
I'm not sure what the deal is anymore.

at one point, jefft told me that the per server pref of "try_ssl" should go
away, we were going to use the per server pref of "auth_method".

if this is the case, there is C++ code and some UI fragments smtpEditOverlay.*
that need to be removed and/or cleaned up.

on a related note, I'm not sure if the per server "auth_method" pref is the way
to go.  are those 5 values for auth_method the ones we want?  do they match up
to what the back end can (will or should be able to) do?  do they cover all the
cases we want to cover?

once we figure that out, we can design and implement a ui to allow users to
configure their SMTP servers properly.

my suggestion is to assign all the SMTP SSL / Auth, SMTP UI bugs to one person,
and let them research and sort it out.

re-assigning to putterman.
Assignee: sspitzer → putterman

Comment 12

17 years ago
The SSL values in auth_method are gone.  Authentication and SSL are orthogonal 
issues.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 13

17 years ago
When sending email I always get an error "Send of message failed" with my auth
set to ssl always. When I sniff the transaction, I see the server send the "go
ahead with TLS transaction" and the client begins but the message still fails.
Are you seeing this behavior jgmyers?

Comment 14

17 years ago
The last comment (and problem) in this bug is a dup of 65703, and since the
preference mentioned in the original scenario is invalid, verifying as invalid.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.