Status

()

Firefox
General
--
minor
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Doug Holton, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b6pre) Gecko/20100914 Firefox-4.0/4.0b6pre Ubuntu/10.04
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b6pre) Gecko/20100914 Firefox-4.0/4.0b6pre Ubuntu/10.04

In the last nightly build, do a search on a web page (control-F), and the find bar at the bottom of the page won't close now when you click on the X.
It does close if you hit the escape key.

Reproducible: Always

Steps to Reproduce:
1. go to any webpage
2. hit control-F
3. click on the X button at the bottom to close the find toolbar
Actual Results:  
find toolbar doesn't close

Expected Results:  
find toolbar should close
This is WORKSFORME.
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre

(Perhaps one of your addons is breaking things?  Try a fresh profile and see if you can reproduce this there -- I can't.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Version: unspecified → Trunk
WORKSFORME on an x86 Ubuntu 10.04 machine, too (same as the reporter):
Mozilla/5.0 (X11; Linux i686; rv:2.0b6pre) Gecko/20100913 Firefox/4.0b6pre
(Reporter)

Comment 3

7 years ago
I disabled addons and still saw the same behavior.
I also moved my profile folder and profiles.ini out and started with a new blank profile and still saw the same behavior.
I also setup firefox sync for the first time (since it has an icon down there, in case it was an issue), but still see the same behavior.
Is your nightly build from the ubuntu-mozilla-daily PPA?  I just tried the latest from there on my x86 Ubuntu 10.04 machine, and it worked for me:
Mozilla/5.0 (X11; Linux i686; rv:2.0b7pre) Gecko/20100914 Firefox-4.0/4.0b7pre Ubuntu/10.04

Could you test the latest trunk build from Mozilla:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-4.0b7pre.en-US.linux-i686.tar.bz2
and report back whether you can reproduce it from that? (Make sure to paste in your user-agent string from Help | About Minefield, to confirm which version you're running)
(Reporter)

Comment 5

7 years ago
The latest nightly doesn't have this issue any more for me.  I noticed they took out some recent problematic commits, not sure which one could have caused the issue.
Resolution: WORKSFORME → FIXED
WORKSFORME is the correct resolution for bugs without a specific patch known to have fixed it. If you want to test hourly builds to figure out which patch (or backout) actually fixed it, feel free to do so and re-resolve as FIXED with a comment pointing to that commit. It would probably be useful feedback anyway if it was due to a backout to ensure that it doesn't break again when the patch re-lands.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.