Close button is difficult to see on tabs with dark coloured thumbnails

VERIFIED FIXED in Firefox 4.0b12

Status

defect
P3
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: shorlander)

Tracking

Trunk
Firefox 4.0b12
x86
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Reporter

Description

9 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre

Currently groups with dark thumbnail images such as the first run video have close buttons that are very difficult to see. Is there anything that can be done to increase the clarity and visibility of the button on dark thumbnails?
Reporter

Updated

9 years ago
Summary: Close button is difficult to see on tabs with black thumbnails (first-run video) → Close button is difficult to see on tabs with dark coloured thumbnails (first-run video)
Wontfix, as bug 596075 is going to remove the first-run video and, because of the group title bar, there should be no other case where thumbnails collide with the group close button.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Reporter

Comment 2

9 years ago
Great, good to see.
Re-opening; even though the first-run video is going away, there are plenty of other dark color web pages in the world. 

Note that on the Mac, the close button is hard to see, but still barely visible due to some light highlighting in the close image. On Windows (and probably Linux) it is in fact impossible to see against a black tab thumbnail, as it's just a black x. 

Assigning to Aza for design.
Assignee: nobody → aza
Status: RESOLVED → REOPENED
Priority: -- → P3
Resolution: WONTFIX → ---
Summary: Close button is difficult to see on tabs with dark coloured thumbnails (first-run video) → Close button is difficult to see on tabs with dark coloured thumbnails

Comment 4

9 years ago
Reassigning for shorlander for visual design.
Assignee: aza → shorlander
Duplicate of this bug: 587449

Updated

9 years ago
Blocks: 598154

Comment 6

9 years ago
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9pre) Gecko/20101220 Firefox/4.0b9pre

I have too often accidentally closed a tab when clicking on a thumbnail in Tab Panorama, because I didn't see the gray X. That is a jarring experience.

I would prefer the close button to be somewhat offset from the thumbnail and always visible.
OS: Mac OS X → All

Comment 7

9 years ago
bugspam (moving b9 to b10)
Blocks: 608028

Comment 8

9 years ago
bugspam (removing b9)
No longer blocks: 598154

Comment 9

9 years ago
I think an even better solution would be to have some kind of hover-over state change to the close button, so you know that you're about to close the butter. I've mistakenly closed tabs a lot, even when I think I'm not over the button.
Shorlander, would you mind if I take this bug and just try a simple white glow on the close button and ui-review? you?
Blocks: 627096
No longer blocks: 608028
Or, even better:

http://24ways.org/2010/calculating-color-contrast

Lucky thing we're using canvas. ;)
(In reply to comment #11)
> Or, even better:
> 
> http://24ways.org/2010/calculating-color-contrast
> 
> Lucky thing we're using canvas. ;)

Thoughts on this:

A) Put the close X glyph in a box that ties into the window close button

B) Put a white outline on the X glyph

C) If you get especially fancy like suggested in comment 11 use a white icon on dark background and a dark icon on light backgrounds; as well as a different style icon for closing the group vs. closing the tab
(In reply to comment #12)
> Thoughts on this:
> 
> A) Put the close X glyph in a box that ties into the window close button
> 
> B) Put a white outline on the X glyph
> 
> C) If you get especially fancy like suggested in comment 11 use a white icon on
> dark background and a dark icon on light backgrounds; as well as a different
> style icon for closing the group vs. closing the tab

I prefer option B. I like that we're using the "close tab" close boxes rather than the "close window" close boxes, and C seems too ambitious at this point.

Can you do up the new PNG?
Stephen, are you working on this?
(In reply to comment #14)
> Stephen, are you working on this?

Yes.
Updates the close icons to be easier to see on a wider range of thumbnails
Attachment #509835 - Flags: review?(ian)
Comment on attachment 509835 [details] [diff] [review]
Update Close Icons - 01

Excellent
Attachment #509835 - Flags: review?(ian) → review+
Comment on attachment 509835 [details] [diff] [review]
Update Close Icons - 01

I was about to say, "hey this needs ui-r," but then I saw who attached the patch.
Attachment #509835 - Flags: approval2.0? → approval2.0+
Is this ready to land?
Pushed.

http://hg.mozilla.org/mozilla-central/rev/fc119d5000e5
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12

Comment 22

9 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110215 Firefox/4.0b12pre

Issue no longer present.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.