If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Undo option is not available when I delete a message from the thread pane

VERIFIED DUPLICATE of bug 62497

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED DUPLICATE of bug 62497
17 years ago
13 years ago

People

(Reporter: msanz, Assigned: Navin Gupta)

Tracking

({dataloss})

Trunk
x86
Windows NT
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using 20001108 branch build, Windows NT US.
I use POP and I download messages to my hard disk	
Steps to reproduce
1. Select a message in the thread pane
2. Click on the Trash icon (message is deleted)
3. Go to Edit menu
Expected: Undo Delete Message option is available
Actual: Undo option is greyed out

I've noticed this only with this build, this was working in previous builds.
Other info: I use Classic skin
(Reporter)

Comment 1

17 years ago
adding rtm, I would love someone could try this one in another machine
Keywords: rtm
(Reporter)

Comment 2

17 years ago
removing rtm, I cannot reproduce  this consistently
Keywords: rtm

Comment 3

17 years ago
reassigning to naving.

msanz, how often are you able to reproduce this?
Assignee: putterman → naving
(Assignee)

Comment 4

17 years ago
worksforme using the 20001108 branch build 
(Reporter)

Comment 5

17 years ago
I haven't been able to reproduce it anymore; mark it worksforme and I will
reopen if I find more info
(Reporter)

Comment 6

17 years ago
OK, different behavior today. When I delete messages, the option under Edit menu
says "Undo Move Message" instead of "Undo Delete Message" and when I select it
the message does not get restored. I'll keep looking into this.
(Assignee)

Comment 7

17 years ago
I am not able to reproduce this using the 20001108 on Window NT. 
(Reporter)

Comment 8

17 years ago
I'm not able to reproduce this consistently either, but I see it once daily at
least. I'm still trying to figure out what makes this menu options to be greyed out.

Updated

17 years ago
QA Contact: esther → sheelar

Comment 9

17 years ago

*** This bug has been marked as a duplicate of 43408 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
I am not sure if this is a dup.  Bug 43408 describes that there was no undo
option available at all. But this bug describes seeing  the option but it is
greyed out and cannot be selected.

Can you tell me why you feel this is the same bug?

Comment 11

17 years ago
buildid-2001-01-16-08 I don't see this problem.  Marking this bug as verified
anyways because this is not seen anymore. 
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

17 years ago
I'd like to reopen the bug; I think it has to do with using Shift+Delete to
delete a message. I know I cannot recover messages this way, but it seems that
after using Shift+Delete to delete a message, even if you delete messages with
just "Delete", the option is not enabled, it's grayed out.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 13

17 years ago
duplicate of bug 38227?

downgrading priority -- this is hardly critical.
Severity: critical → normal

Updated

17 years ago
Keywords: dataloss
(Assignee)

Comment 14

17 years ago
After shift-delete if you delete, you can still undo. Marking wfm using 
today's debug build 
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 15

17 years ago
branch build 2001070206 win98 imap worksfine but not from pop account. 
Shift+delete mssg and undo option is not available.

2001070205 mac can undo when deleted from file menu, toolbar. Could not delete a 
message using shift+delete key to delete a message.

2001070204 linux-undo works when message deleted from menu item, toolbar button 
on imap and pop. But only on pop when deleting a message as shift+delete-undo is 
disabled in the menu item.

reopening 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 16

16 years ago
bug 62497 is open for the shift delete problem, so this one doesn't need to be
re-opened. dup'ing.

*** This bug has been marked as a duplicate of 62497 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.