[pp]Attempting to print page results in crash.

VERIFIED DUPLICATE of bug 58900

Status

()

Core
Printing: Output
P3
normal
VERIFIED DUPLICATE of bug 58900
18 years ago
18 years ago

People

(Reporter: Chris Petersen, Assigned: dcone (gone))

Tracking

Trunk
All
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build: 2000110800
Platform: Mac and Windows
Expected results: Application should print page and not crash.
What I got: The application crashes.

Steps to reproduce:

1) Got to http://www.msnbc.com/news/466882_asp.htm

2) Print page.

3) Application crashes.
(Reporter)

Comment 1

18 years ago
Stack trace for windows crash:

sContainerFrame::PositionChildViews(nsIPresContext * 0x04f1bef0, nsIFrame *
0x0100fa00) line 747 + 17 bytes
nsContainerFrame::PositionChildViews(nsIPresContext * 0x04f1bef0, nsIFrame *
0x0100f9a0) line 756 + 13 bytes
nsTableRowFrame::ResizeReflow(nsTableRowFrame * const 0x0100f688, nsIPresContext
* 0x04f1bef0, nsHTMLReflowMetrics & {...}, RowReflowState & {...}, unsigned int
& 0, int 0) line 1009 + 13 bytes
nsTableRowFrame::Reflow(nsTableRowFrame * const 0x0100f688, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1541 + 33 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0100f688, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 42578, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
nsTableRowGroupFrame::ReflowMappedChildren(nsTableRowGroupFrame * const
0x010376e8, nsIPresContext * 0x04f1bef0, nsHTMLReflowMetrics & {...},
RowGroupReflowState & {...}, unsigned int & 0, nsTableRowFrame * 0x00000000,
nsReflowReason eReflowReason_Resize, int 1, int 0) line 422 + 45 bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x010376e8,
nsIPresContext * 0x04f1bef0, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, unsigned int & 0) line 1091 + 38 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x010376e8, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
nsTableFrame::ReflowMappedChildren(nsTableFrame * const 0x01037780,
nsIPresContext * 0x04f1bef0, nsHTMLReflowMetrics & {...}, InnerTableReflowState
& {...}, unsigned int & 0) line 3132 + 47 bytes
nsTableFrame::ResizeReflowPass2(nsTableFrame * const 0x01037780, nsIPresContext
* 0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 2074 + 31 bytes
nsTableFrame::Reflow(nsTableFrame * const 0x01037780, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1714 + 34 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x01037780, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 3, unsigned int & 0) line 693 + 31 bytes
nsTableOuterFrame::OuterReflowChild(nsTableOuterFrame * const 0x0103772c,
nsIPresContext * 0x04f1bef0, nsIFrame * 0x01037780, const nsHTMLReflowState &
{...}, nsHTMLReflowMetrics & {...}, int * 0x00000000, nsSize & {...}, nsMargin &
{...}, nsMargin & {...}, nsMargin & {...}, nsReflowReason eReflowReason_Resize,
unsigned int & 0) line 900 + 47 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x0103772c, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1440 + 69 bytes
nsBlockReflowContext::DoReflowBlock(nsHTMLReflowState & {...}, nsReflowReason
eReflowReason_Resize, nsIFrame * 0x0103772c, const nsRect & {...}, int 0, int 0,
int 1, nsMargin & {...}, unsigned int & 0) line 561 + 36 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x0103772c, const nsRect & {...},
int 0, int 0, int 1, nsMargin & {...}, unsigned int & 0) line 331 + 50 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x010377e8, int * 0x0012e34c) line 3879 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x010377e8, int
* 0x0012e34c, int 0) line 3142 + 23 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2949 + 27 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x01037810, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1740 + 15 bytes
nsBlockReflowContext::DoReflowBlock(nsHTMLReflowState & {...}, nsReflowReason
eReflowReason_Resize, nsIFrame * 0x01037810, const nsRect & {...}, int 0, int 0,
int 1, nsMargin & {...}, unsigned int & 0) line 561 + 36 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x01037810, const nsRect & {...},
int 0, int 0, int 1, nsMargin & {...}, unsigned int & 0) line 331 + 50 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x0103785c, int * 0x0012ee84) line 3879 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x0103785c, int
* 0x0012ee84, int 0) line 3142 + 23 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2949 + 27 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x010378bc, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1740 + 15 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x010378bc, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
nsPageFrame::Reflow(nsPageFrame * const 0x01037884, nsIPresContext * 0x04f1bef0,
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 129
nsContainerFrame::ReflowChild(nsIFrame * 0x01037884, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int
100, int 15538, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
nsSimplePageSequenceFrame::IncrementalReflow(nsIPresContext * 0x04f1bef0, const
nsHTMLReflowState & {...}, nsSize & {...}, int 100, int & 15538) line 173
nsSimplePageSequenceFrame::Reflow(nsSimplePageSequenceFrame * const 0x00fcd4a4,
nsIPresContext * 0x04f1bef0, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, unsigned int & 0) line 233
nsContainerFrame::ReflowChild(nsIFrame * 0x00fcd4a4, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x00fcd468, nsIPresContext *
0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 546
nsHTMLReflowCommand::Dispatch(nsHTMLReflowCommand * const 0x04e64580,
nsIPresContext * 0x04f1bef0, nsHTMLReflowMetrics & {...}, const nsSize & {...},
nsIRenderingContext & {...}) line 146
PresShell::ProcessReflowCommands(int 1) line 5106
ReflowEvent::HandleEvent() line 4989
HandlePLEvent(ReflowEvent * 0x04e2cbf0) line 5003
PL_HandleEvent(PLEvent * 0x04e2cbf0) line 576 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00ac93b0) line 509 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x092d025e, unsigned int 49342, unsigned int 0,
long 11310000) line 1054 + 9 bytes
USER32! 77e71820()
00ac93b0()



(Reporter)

Comment 2

18 years ago
This bug might be related to 58900.
(Assignee)

Comment 3

18 years ago
I am sure this is a duplicate of that.. but when that bug is solved.. this page 
should be check against that.

*** This bug has been marked as a duplicate of 58900 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
verif dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.