Preponderance of Mac trunk crashes with no symbols for XUL library

RESOLVED DUPLICATE of bug 596700

Status

RESOLVED DUPLICATE of bug 596700
8 years ago
7 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Seen while reviewing Mac specific crash stats - using a diff between 9/14 and 9/15 - there are a number of crashes that look like the following (5 out of the top 6 Mac Trunk crashes, and there are more down the line)

@XUL@20c1c7 - http://tinyurl.com/29pt3k6
@XUL@10aae50 - http://tinyurl.com/29vykeh
@XUL@b010e7 - http://tinyurl.com/25px5ru
@XUL@ba001 - http://tinyurl.com/2dhl4mf
@XUL@ba29a9 - http://tinyurl.com/2dncqd5
There seem to be a fair number of Windows reports that are showing up as well when I look at the overall crash stats picture today.

Updated

8 years ago
Depends on: 596700

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 596700
I just crashed on trunk and got this report: https://crash-stats.mozilla.com/report/index/3d5a68e3-b95e-4368-9684-cd3cf2100915, and there are no symbols.
Here is the same crash that I got on 2010-09-13 using a trunk build with build id: 20100913030652

http://crash-stats.mozilla.com/report/index/7cebacdc-59cf-4544-b737-cb72d2100913

Compare this to the crash above, which happened today (2010-09-15) after the other bug was fixed is using today's Mac trunk build (20100915031022)

https://crash-stats.mozilla.com/report/index/3d5a68e3-b95e-4368-9684-cd3cf2100915
Marcia, I need some clarification - the two crash appear to be totally different.  

If you compare the "raw dump" tabs of the two crashes (the output for the stackwalker), there are many differences: one crashes in thread 0 and the other crashes in thread 2.  If you scroll down to the frames, you'll see that the frame sets are very different.  In addition, any frame from XUL is fully equipped with proper symbols in both crashes.  

Did you post the correct crashes to compare?
(Assignee)

Updated

7 years ago
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.